Closed Bug 1125048 Opened 6 years ago Closed 5 years ago

Slow fling speed with thumb flings (high DPI)

Categories

(Firefox for Android :: Toolbar, defect)

ARM
Android
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1047127
Tracking Status
fennec 39+ ---

People

(Reporter: gcp, Assigned: snorp)

References

Details

(Keywords: perf, Whiteboard: profile-wanted)

Related to bug 1056619.

Observed on current Nightly.

STR:
1) Acquire high DPI device like a Nexus 9
2) Load webpage like http://anandtech.com/show/8923/nvidia-launches-geforce-gtx-960
3) Hold device normally, fling down a page with your tumb as fast as you can
4) Observe very slow scrolling on Firefox

On my Nexus 9, I usually get somewhere between the "memory compression" slide and the graph before that.

Same operation with Chrome: between the "Sweet spot GPU" and "Expanded MFAA" graphic.

IMHO it's very easy to notice the scroll speed of Firefox is unnaturally slow here.
Blocks: 1056619
Is this a regression from bug 105661? Can you check a prior build (or fiddle with prefs to disable that behavior) and see if you end up going significantly farther on the same page?
Flags: needinfo?(gpascutto)
I think that's bug 1100315 right. I'm only doing a single fling so bug 721421 should be irrelevant.
Flags: needinfo?(gpascutto)
Err yeah. Sorry I assumed you were referring to bug 1100315 since 1056619 is WFM. Still, my question stands: is this a regression, or was it just always like this?
tracking-fennec: --- → ?
Flags: needinfo?(gpascutto)
I tested a build with dd9ba31c3cfc backed out but I see no difference. I'll try a few releases and see if we got worse at some point.
Flags: needinfo?(gpascutto)
All the Firefox versions that are able to run on this device (32+) are slow. I do not think this is a regression.
Kats can you look into this please?
Flags: needinfo?(bugmail.mozilla)
Nexus 6 Economist, everything is clunky 

http://people.mozilla.org/~atrain/mobile/nexus-6-economist.mp4

I'll try and get a profile sometime soon.
Keywords: perf
Whiteboard: profile-wanted
Not in the immediate future, and anyway I don't have that device so it's unlikely I'll be able to fix it myself. Somebody should look into what GeckAppShell.getDpi() is returning on the device and if it makes sense. That would be the first step.
Flags: needinfo?(bugmail.mozilla)
D/GeckoAppShell( 9143): getDpi: 320
D/GeckoAppShell( 9143): getDensity: 2.0

Real value is 281 ppi.
Assignee: nobody → gpascutto
tracking-fennec: ? → 37+
tracking-fennec: 37+ → ---
tracking-fennec: --- → ?
Assignee: gpascutto → snorp
tracking-fennec: ? → 37+
I have a Nexus 9 now, and can't reproduce this. I tried with the URL in comment #0 and things seem normal to me. https://www.dropbox.com/s/dez27bcvha0voik/fling.mp4
gcp can you still reproduce this? I wonder if you were seeing the dreaded sync scrolling in a div behavior and now they just changed their site?
Flags: needinfo?(gpascutto)
Might be a dupe of bug 1047127
 
   test-case: http://people.mozilla.org/~mwargers/tests/panning/overflowx_scrolling.html

or bug 1035876 where Gecko is falling back to synchronous scrolling in an overflow:scroll div that's scrolling

   test-case: http://time.com/3726560/pot-dispensing-rabbi-d-c-residents-deserve-legal-access-to-marijuana/
Yeah, pretty sure this is a dup. Since this requires switching to the native APZC, I recommend untracking for 37.
Status: NEW → RESOLVED
tracking-fennec: 37+ → ?
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1047127
tracking-fennec: ? → 39+
Flags: needinfo?(gpascutto)
You need to log in before you can comment on or make changes to this bug.