Closed Bug 1047158 Opened 5 years ago Closed 5 years ago

[User Story] Snapping Task Switcher Cards into Position

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 1061324
tracking-b2g backlog

People

(Reporter: rmacdonald, Unassigned)

References

Details

(Whiteboard: [systemsfe][tako])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
rmacdonald
: ui-review-
Details | Review
As a user, I want the card that is closest to the middle of screen in Task Switcher to snap to the center of the screen when scrolling stops.

Acceptance Criteria:
1) The Task Switcher card snaps to the center of the screen as defined in the Task Switcher animation specs.
Attached file Github patch
Attachment #8468417 - Flags: ui-review?(rmacdonald)
This story needs to depend on 1045784 where we are implementing the horizontal row of cards (vs the existing carousel style). In that design, we scroll left and right to access open apps/sheets and need a solution to "snap" to center the nearest card.
Depends on: 1045784
Comment on attachment 8468417 [details] [review]
Github patch

Hi Markus...

 Finally able to resolve the patch issues and downloaded it only to see Sam's earlier comment. This patch is really dependent upon the work he is doing. Please flag myself or Francis at that time. I will be on PTO until August 18 and Francis will be reviewing patches in my absence.

Thanks!
Rob
Attachment #8468417 - Flags: ui-review?(rmacdonald) → ui-review-
feature-b2g: --- → 2.1
As it stands, the implementation in bug 1045784 uses native scrolling for the row of cards. This gets us the right responsiveness and physics "for free". However, with this approach, we can't get good snapping behavior from js/css without bug 945584. In recent discussions with UX the snapping behavior was deemed less important than smooth, consistent scrolling and something we could - if necessary - ship without in 2.1. So, my understanding is that 945584 does block this feature, but this feature is a nice-to-have for 2.1 

Rob is on PTO. Francis, can you confirm?
Depends on: 945584
Flags: needinfo?(fdjabri)
Clearing flag for Francis, we discussed this Friday and the free-scrolling, not-snapping scrolling behavior was confirmed as ok for 2.1
Flags: needinfo?(fdjabri)
blocking-b2g: --- → backlog
feature-b2g: 2.1 → ---
Removing from meta as this is not a blocker for 2.1.
No longer blocks: soft-home-button
Also, this was fixed in bug 1061324, so duping.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061324
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.