Closed Bug 1036339 (soft-home-button) Opened 6 years ago Closed 5 years ago

[meta] Software home button improvements for 2.1

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S3 (29aug)
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: etienne, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe][tako][2.1-feature-qa+])

Attachments

(2 files, 1 obsolete file)

The spec is still in the work, but we already have some code :)
So tracking...
Depends on: 1032768
Depends on: 1036340
Depends on: 1037251
Depends on: 1037255
Depends on: 1037261
Depends on: 1037279
Depends on: 1038671
No longer depends on: 1032768
Assignee: nobody → mhenretty
feature-b2g: --- → 2.1
Whiteboard: [systemsfe][tako]
Target Milestone: --- → 2.1 S3 (29aug)
Depends on: 1047115
Depends on: 1047126
Depends on: 1047158
Depends on: 1047660
QA Whiteboard: [2.1-feature-qa+]
Flags: in-moztrap?(jsmith)
QA Contact: jsmith
QA Whiteboard: [2.1-feature-qa+]
Whiteboard: [systemsfe][tako] → [systemsfe][tako][2.1-feature-qa+]
Adding the spec for reference.
Depends on: 1047163
Depends on: 1054126
Flags: in-moztrap?(jsmith) → in-moztrap?(mozbugs.retornam)
QA Contact: jsmith → mozbugs.retornam
Depends on: 1055198
Flags: in-moztrap?(mozbugs.retornam) → in-moztrap?(echang)
QA Contact: mozbugs.retornam → echang
Alias: soft-home-button
QA Whiteboard: [COM=Gaia::System]
Removing feature-b2g:2.1 since this is a meta bug.
feature-b2g: 2.1 → ---
Depends on: 1048620
Depends on: 1058675
Attached file VsD_Soft_Home_Button_Specification.pdf (obsolete) —
Note: the decision to go with a dot or the normal ring shaped icon is pending a review of Markus' demo videos.
Updated Spec with final recommendation to go with ring shaped home button icon in all cases.
Attachment #8479567 - Attachment is obsolete: true
Depends on: 1059967
Depends on: 1060693
Mike - Is this feature completely landed at this point for 2.1? Or do we have anything left here? Just want to know if we can close this out as feature landed for 2.1 at this point.
Flags: needinfo?(mhenretty)
Depends on: 1061962
Yup, this can be closed. The rest is polish and bug fixes.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mhenretty)
Resolution: --- → FIXED
Depends on: 1064327
QA Whiteboard: [COM=Gaia::System] → [COM=Gaia::System][needs-verification]
The Home button does remain in the proper area when the user is in landscape or portait mode. The SHB is not covered up when transitioning between apps using edge gestures while using different orientations.

However, I cannot verify this bug as fixed.

Several issues still exist, as outlined in the Spec sheet, and PDF attached to this bug.

-The SHB does not highlight blue when it is tapped on. 
-The SHB does not become transparent on the lockscreen. 
-The SHB does not dissapear when viewing a fullscreen video. https://bugzilla.mozilla.org/show_bug.cgi?id=1055198
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::System][needs-verification] → [QAnalyst-Triage?][COM=Gaia::System]
Flags: needinfo?(ktucker)
Status: VERIFIED → RESOLVED
Closed: 6 years ago5 years ago
QA Whiteboard: [QAnalyst-Triage?][COM=Gaia::System] → [QAnalyst-Triage+][COM=Gaia::System]
Depends on: 1064595
Flags: needinfo?(ktucker)
The SHB not highlighting blue when tapped on seems minor and not a blocker. 

The home button appearing on the lockscreen as stated in bug 1064595 to me is a blocker.

The SHB does not hide when apps have a full screen layout and when viewing videos and photos in full screen. I think is a blocker as well. See bug 1037279 bug 1055198 bug 1064327

This issue cannot be verified as fixed.
Discussed comment 9 with Mike - the fullscreen bugs are Flame-specific, which won't reproduce on Tako. As such, we aren't going to block on those issues for 2.1. There is agreement that bug 1064595 should be a blocker though, which means this feature did not pass FL signoff. We need bug 1064595 fixed to achieve FL signoff of this feature.
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::System] → [QAnalyst-Triage+][COM=Gaia::System][failed-verification]
No longer depends on: 1037279
No longer depends on: 1047158
No longer depends on: 1055198
No longer depends on: 1059967
No longer depends on: 1064327
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::System][failed-verification] → [QAnalyst-Triage+][COM=Gaia::System][needs-verification]
Depends on: 1067441
Verifying this as implemented for Flame 2.2(319mb)(Master)

The Home button does remain in the proper area when the user is in landscape or portait mode. The SHB is not covered up when transitioning between apps using edge gestures while using different orientations.

-The SHB does become transparent on the lockscreen. 

I am unable to verify this Feature as landed, due to the SHB still showing up on the lockscreen. Bug 1064595 has not been uplifted to 2.1 yet.

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140915040203
Gaia: 855be6ade407c26e0596e7306a44deebc3f60933
Gecko: f27ff178807d
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 (319mb)

Environmental Variables:
Device: Flame Master
BuildID: 20140915000203
Gaia: 944e5b4582c4efa1b67cd33245dbb8f6aa25d09f
Gecko: 7546fedad918
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(ktucker)
Status: RESOLVED → VERIFIED
Derek - Why is this marked verified with bug 1067441 open?
Flags: needinfo?(dharris)
Bug 1067441 is blocking verification of this bug
Status: VERIFIED → RESOLVED
Closed: 5 years ago5 years ago
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::System][needs-verification] → [QAnalyst-Triage+][COM=Gaia::System][failed-verification]
Flags: needinfo?(dharris)
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::System][failed-verification] → [QAnalyst-Triage+][COM=Gaia::System][needs-verification]
Depends on: 1074608
Depends on: 1077579
derek, please verifyme against the dependency bugs on this list, now that bug 1067441 was fixed awhile ago.
Flags: needinfo?(dharris)
Keywords: verifyme
I will attempt to verify this bug on tomorrows nightly build. Cannot verify this bug as fixed until bug 1079525 has been verified first.
Flags: needinfo?(dharris)
Besides bug 1077579 (which is just a tracking bug), all depends on of this bug have been verified fixed. Also all issues mentioned in comment 8 and comment 11 are verified fixed. Marking this bug as verified fixed for Flame 2.1 and Flame 2.2


Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Gaia::System][needs-verification] → [QAnalyst-Triage?][COM=Gaia::System]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][COM=Gaia::System] → [QAnalyst-Triage+][COM=Gaia::System]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.