Closed Bug 1047406 Opened 5 years ago Closed 5 years ago

Remove conversation window notifications; implement title changes when displaying feedback form (form currently overflows window)

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox34 verified, firefox35 verified)

VERIFIED FIXED
mozilla35
Iteration:
35.3
Tracking Status
firefox34 --- verified
firefox35 --- verified

People

(Reporter: standard8, Unassigned)

References

Details

(Whiteboard: [regression][loop-uplift])

User Story

* Remove the existing notifications in the conversation window.
* When a connected call ends (success or fails):
** Display the feedback form (as currently after bug 972992).
** Change the title bar to read:
*** On success: "Call Ended"
*** On failure: "Call Failed"

Attachments

(1 file)

Bug 972992 is implementing the feedback form on desktop.

Currently when hitting the sad face, the bottom of the feedback form is hidden and you have to scroll to show the button. We discussed with Darrin, and came up with the requirements, as described by the user story.
User Story: (updated)
Depends on: 1047410
Priority: -- → P2
Priority: P2 → P1
Whiteboard: [regression]
Whiteboard: [regression] → [regression][loop-uplift]
Target Milestone: mozilla34 → mozilla35
Assignee: nobody → nperriault
This patch removes the use of the NotificationCollection in the conversation window, and uses window title changes to notify the end user about call state changes.

This is to be considered as a transition until bug 1047410 lands, code has been heavily commented about this.
Attachment #8498127 - Flags: review?(standard8)
Comment on attachment 8498127 [details] [diff] [review]
Remove notifications in Loop conversation window.

Review of attachment 8498127 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=Standard8
Attachment #8498127 - Flags: review?(standard8) → review+
https://hg.mozilla.org/mozilla-central/rev/7dde79b5e40e
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Pauly -- This is ready to verify.  Thanks!
Flags: needinfo?(paul.silaghi)
Couple of issues here, not all of them related to this bug:
1. the outgoing call window doesn't display 'call failed' in the title bar, just 'Something went wrong' in the window's layout. 'Call failed' for the incoming call window cannot be tested yet (bug 1076794)
2. the outgoing call window displays the opponent's email address in the title bar while ringing, the incoming call window displays 'conversation request' while ringing. It displays 'conversation request' even after accepting the call
3. no call ended/failed notification for the guest callers (link clickers), just the feedback window
4. a new call won't start if the outgoing call window is opened (showing feedback or retry/cancel)
Please advise what needs to be filed.
Flags: needinfo?(paul.silaghi) → needinfo?(standard8)
Flags: qe-verify+
QA Contact: paul.silaghi
(In reply to Paul Silaghi, QA [:pauly] from comment #6)
> Couple of issues here, not all of them related to this bug:
> 1. the outgoing call window doesn't display 'call failed' in the title bar,
> just 'Something went wrong' in the window's layout. 'Call failed' for the
> incoming call window cannot be tested yet (bug 1076794)

So I haven't yet asked explicit UX review on this, but the intention with keeping the title bar as the user's name, was to keep the user aware of who would be called in the event of a retry. If we put the something went wrong in the title bar, then it'd be unclear as to who the window is for. If you want to file a bug to verify the UX here, that's fine.

> 2. the outgoing call window displays the opponent's email address in the
> title bar while ringing, the incoming call window displays 'conversation
> request' while ringing. It displays 'conversation request' even after
> accepting the call

The incoming call window is bug 1020449

> 3. no call ended/failed notification for the guest callers (link clickers),
> just the feedback window

That's correct, "call ended" quietly went away from the UX specs. The "Your conversation has ended" is the right thing to display.

> 4. a new call won't start if the outgoing call window is opened (showing
> feedback or retry/cancel)

That's a side-effect of the busy handling. I think it would be worth filing a bug - we should probably allow a new call when in the feedback state, but not any other.
Flags: needinfo?(standard8)
Depends on: 1079816
(In reply to Mark Banner (:standard8) from comment #7)
> (In reply to Paul Silaghi, QA [:pauly] from comment #6)
> > Couple of issues here, not all of them related to this bug:
> > 1. the outgoing call window doesn't display 'call failed' in the title bar,
> > just 'Something went wrong' in the window's layout. 'Call failed' for the
> > incoming call window cannot be tested yet (bug 1076794)
> So I haven't yet asked explicit UX review on this, but the intention with
> keeping the title bar as the user's name, was to keep the user aware of who
> would be called in the event of a retry. If we put the something went wrong
> in the title bar, then it'd be unclear as to who the window is for. If you
> want to file a bug to verify the UX here, that's fine.
bug 1079816

> > 3. no call ended/failed notification for the guest callers (link clickers),
> > just the feedback window
> That's correct, "call ended" quietly went away from the UX specs. The "Your
> conversation has ended" is the right thing to display.
I was trying to say that no message of this type is displayed on the link clicker's (guest) side

> > 4. a new call won't start if the outgoing call window is opened (showing
> > feedback or retry/cancel)
> That's a side-effect of the busy handling. I think it would be worth filing
> a bug - we should probably allow a new call when in the feedback state, but
> not any other.
bug 1079811

I'm marking this bug as verified fixed since the existing notifications are removed from the conversation window and 'call ended' is displayed in the title bar. The work continues in bug 1076794 and bug 1079816
Status: RESOLVED → VERIFIED
Depends on: 1076794
Comment on attachment 8498127 [details] [diff] [review]
Remove notifications in Loop conversation window.

Approval Request Comment
Part of the staged Loop aurora second uplift set
Attachment #8498127 - Flags: approval-mozilla-aurora?
Flags: needinfo?(paul.silaghi)
Comment on attachment 8498127 [details] [diff] [review]
Remove notifications in Loop conversation window.

Already landed in aurora, approving for posterity
Attachment #8498127 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed FF 34b1 Win 7
Flags: needinfo?(paul.silaghi)
Iteration: --- → 35.3
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.