Take advantage of nsIURIFixup improvements for faster location bar searches

RESOLVED FIXED in Firefox 34

Status

()

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: Margaret, Assigned: bnicholson)

Tracking

Trunk
Firefox 34
All
Android
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

Bug 693808 improved location bar searches for desktop. We should take advantage of these platform changes to do the same thing!

IIRC, we have some of our own custom logic in place to try band-aid over some of these problems, but it seems like we could have a real solution now.

http://msujaws.wordpress.com/2014/08/01/faster-and-snappier-searches-now-in-firefox-aurora/
Flags: needinfo?(bnicholson)
Depends on: 854305
Since these hacks were a workaround for bug 693808, we can remove them now that bug 693808 has landed. I can confirm that number queries still work (and searches in general are faster, which is nice).
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
Attachment #8467169 - Flags: review?(margaret.leibovic)
Flags: needinfo?(bnicholson)
Comment on attachment 8467169 [details] [diff] [review]
Remove URL search hacks

Review of attachment 8467169 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Attachment #8467169 - Flags: review?(margaret.leibovic) → review+
Should we file a follow-up bug to add a notification asking users if they actually do want to try navigating to a locally hosted site, similar to what desktop has now? The unfortunate thing is that we only have doorhangers, not notification bars, so this would be more disruptive to users. 

Perhaps we should just add some developer setting for that?
(In reply to :Margaret Leibovic from comment #3)
> Should we file a follow-up bug to add a notification asking users if they
> actually do want to try navigating to a locally hosted site, similar to what
> desktop has now? The unfortunate thing is that we only have doorhangers, not
> notification bars, so this would be more disruptive to users. 

It's also more disruptive for us since we have a single input box that merges the location bar and search bar, so it would appear more frequently on mobile. Not sure how much we care about having this, but filed bug 1048533 to track it.
https://hg.mozilla.org/mozilla-central/rev/3c1d7f138339
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Bug 693808 was uplifted to 33. Should we uplift this?
Flags: needinfo?(bnicholson)
(In reply to :Margaret Leibovic from comment #7)
> Bug 693808 was uplifted to 33. Should we uplift this?

Don't think there's any reason to since there's no user-facing change. Bug 854305 and bug 693808 essentially accomplish the same thing; they're redundant, but not conflicting.
Flags: needinfo?(bnicholson)
tracking-fennec: ? → +
Flags: qe-verify?
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.