Can't install jar's with file:// url

RESOLVED DUPLICATE of bug 113949

Status

()

P2
critical
RESOLVED DUPLICATE of bug 113949
17 years ago
17 years ago

People

(Reporter: petecoolrulez, Assigned: darin.moz)

Tracking

({crash})

Trunk
mozilla0.9.8
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I tried installing the theme I'm working on from the hard disk, using an html
file with an InstallTrigger. The url was right, when put in the address bar it
opened the file. When on the html page, clicking the InstallTrigger gave me the
usual prompt ( "Install theme from location" ), to which I agreed; it starts to
fetch the file, and then crashes mozilla. I was able to repeat this issue
numerous times.
Reporter: 
Which build are you using ?
Please include in all bug reports the build ID !

BTW: 
Have you tried file:/// (file:///c:/test.jar)  ?
Can you attach the trigger-File to this bug (via create attachment)
cofirming with win2k build 20011013.. (CVS debug)
I used :

Place a test.jar in c:\ and type this in the URL bar:
javascript:InstallTrigger.installChrome(InstallTrigger.SKIN,'file://test.jar','c
rash now !');

win2k stack trace:
nsXPInstallManager::OnProgress(nsXPInstallManager * const 0x045ba9a8, nsIRequest 
* 0x04580e9c, nsISupports * 0x00000000, unsigned int 16384, unsigned int 216550) 
line 830 + 21 bytes
XPTC_InvokeByIndex(nsISupports * 0x045ba9a8, unsigned int 3, unsigned int 4, 
nsXPTCVariant * 0x03aead80) line 154
EventHandler(PLEvent * 0x03aeadf8) line 514 + 41 bytes
PL_HandleEvent(PLEvent * 0x03aeadf8) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00e627b0) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x004c0230, unsigned int 49427, unsigned int 0, 
long 15083440) line 1071 + 9 bytes
USER32! 77e02e98()
USER32! 77e030e0()
USER32! 77e05824()
nsAppShellService::Run(nsAppShellService * const 0x00f47180) line 457
main1(int 2, char * * 0x003577d0, nsISupports * 0x00000000) line 1291 + 32 bytes
main(int 2, char * * 0x003577d0) line 1619 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87d08()
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Installer → Installer: XPInstall Engine
Ever confirmed: true
Keywords: crash
QA Contact: bugzilla → jimmylee
(Reporter)

Comment 3

17 years ago
This is repeatable here with both 0.9.4 (2001091303 - win98) and 0.9.5
(2001101117 - win2000)

I don't need to add any more info as Matthias Versen's comment said it all.
(Reporter)

Comment 4

17 years ago
Created attachment 53524 [details]
THe original trigger file

Comment 5

17 years ago
David, can you take a look at this?
Assignee: syd → dprice

Comment 6

17 years ago
No problem.

The function nsXPInstallManager::OnProgress is passed an nsIRequest*
That is then QueryInterface'd to an nsIChannel
The QI is failing.  The code currently tosses an assert.  The quick and dirty
fix would be to simply check the result of the QI and fail.  

nsIRequest is an nsIFileTransport  The right thing to do would be to make
certain the file transport supports the nsIChannel interface. 

Comment 7

17 years ago
Spoke to dveditz about this one.  Looks like it is a necko problem

Over to darin

This is a case where we're getting a null channel that "will never happen"
Assignee: dprice → darin
(Assignee)

Comment 8

17 years ago
ok, so the file channel is letting file transport requests slip out... bad file
channel!  should be an easy fix.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Priority: -- → P2
Target Milestone: --- → mozilla0.9.6

Updated

17 years ago
Blocks: 105781
(Assignee)

Comment 9

17 years ago
-> 0.9.8
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Comment 10

17 years ago
Changing QA Contact to Ben.  Changing Component from XPInstall to Networking. 
Please update accordingly if I didn't quite get the changes right.  Thanks!
Component: Installer: XPInstall Engine → Networking
QA Contact: jimmylee → benc
(Assignee)

Comment 11

17 years ago
looks like a dupe of a bug 113949, which i just recently fixed.  can someone
confirm that this is now fixed in a recent night build?

*** This bug has been marked as a duplicate of 113949 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
this is fixed for me with an 1h old CVS build. (no crash)
(Assignee)

Comment 13

17 years ago
great!
You need to log in before you can comment on or make changes to this bug.