Black bar appears Google spreadsheets

VERIFIED FIXED in Firefox 34

Status

()

Core
Graphics: Layers
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: nical)

Tracking

({regression})

34 Branch
mozilla34
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox33 unaffected, firefox34- verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8466607 [details]
screenshot

Steps To Reproduce:
1. Login Google
2. Create new spreadsheets
3. Double click a cell

Actual Results:
Black bar appears
(Reporter)

Comment 1

4 years ago
[Tracking Requested - why for this release]: regressed by Bug 1042052

Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/68e96eb00d3e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140725154406
Bad:
https://hg.mozilla.org/mozilla-central/rev/e07264876182
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140726030204
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=68e96eb00d3e&tochange=e07264876182


Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a6758d669350
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140725014111
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/780188e2dab7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140725022609
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a6758d669350&tochange=780188e2dab7

regressed by:
780188e2dab7	Nicolas Silva — Bug 1042052 - Add TextureClient::CreateSimilar and have component alpha buffer be of the same type. r=sotaro
Blocks: 1042052
status-firefox33: --- → unaffected
status-firefox34: --- → affected
tracking-firefox34: --- → ?
Component: General → Graphics: Layers
Keywords: regression
(Reporter)

Comment 2

4 years ago
Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 200
Device ID: 0x954f
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16492)
Driver Date: 4-29-2013
Driver Version: 8.970.100.1100
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 00000000
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
(Assignee)

Updated

4 years ago
Assignee: nobody → nical.bugzilla
(Assignee)

Comment 3

4 years ago
Created attachment 8467045 [details] [diff] [review]
Pass the proper flag in CreateSimilar

That was a very silly mistake, shame on me.
Attachment #8467045 - Flags: review?(bas)
Comment on attachment 8467045 [details] [diff] [review]
Pass the proper flag in CreateSimilar

Review of attachment 8467045 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/TextureDIB.cpp
@@ +26,5 @@
>  }
>  
>  TemporaryRef<TextureClient>
>  DIBTextureClient::CreateSimilar(TextureFlags aFlags,
>                                    TextureAllocationFlags aAllocFlags) const

nit: shame on you for copying this from ShmemTextureClient and not changing indentation too ;)
Attachment #8467045 - Flags: review?(bas) → review+
QA Whiteboard: [qa+]

Comment 8

4 years ago
https://hg.mozilla.org/mozilla-central/rev/c940f5389094
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Since this has been fixed I see no reason to track at this time.
tracking-firefox34: ? → -
Reproduced using Nightly 2014-08-01 when double clicking for the first time a cell from a new google spreadsheet in an e10s window.
The issue no longer occurs with Firefox 34 beta 1 (20141014134955).
Status: RESOLVED → VERIFIED
status-firefox34: affected → verified
You need to log in before you can comment on or make changes to this bug.