Closed Bug 1047854 Opened 7 years ago Closed 4 years ago

"Advanced Search" options missing on Google search in Firefox for Android (vs Chrome)

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 975444

People

(Reporter: o2733231, Assigned: karlcow)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [country-all] [sitewait] [serversniff])

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Perform a search at toogle


Actual results:

Missing option to specify date interval for the results


Expected results:

show it like in chrome
Attached image Screenshot_chrome.png
Attached image Screenshot_firefox.png
Google sends us different content than Chrome.
Status: UNCONFIRMED → NEW
Component: General → Mobile
Ever confirmed: true
OS: Windows 7 → Android
Product: Firefox for Android → Tech Evangelism
Hardware: x86_64 → ARM
Version: Firefox 31 → unspecified
Summary: Advanced search options missing on google search engine → "Advanced Search" options missing on Google search in Firefox for Android (vs Chrome)
Confirmed and same issue with Firefox OS.

With the following sequence:
1. Go to http://google.com/
2. (Being redirected to your local google) Forcing google.com just for the sake of consistency.
3. Search for 'Onchi Koshiro'
4. The top menu before the search results is

   4.1 On Opera: [Web] [Videos] [Images] [Shopping] [More]
       In the More Menu, there are additional options, the 
       last one being [Search tools] giving access to time filtering.

   4.2 On Firefox (Android): [Web] [Images] [More]
       In the More Menu, there are additional options BUT NOT
       search tools. There is an even more menu leading to a list 
       of apps on a different page.

   4.3 On Firefox OS: Same thing than 4.2
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-all] [contactready] [serversniff]
I contacted google about it.
Whiteboard: [country-all] [contactready] [serversniff] → [country-all] [contacted] [serversniff]
Attached image opera-search-tools.png
Opera Screenshot showing the working feature
Whiteboard: [country-all] [contacted] [serversniff] → [country-all] [sitewait] [serversniff]
Attached image opera-time-filter.png
Opera Screenshot showing the working feature
Newest opera uses chrome engine
Duplicate of this bug: 1106267
I noticed that the tablet UI seems to have a better google search experience than the phone UI.

See bug #921536 comment #10 for details on a closely related problem with the google search page menu, and note the improvement in the behaviour of the "white menu bar below the search box that [now] offers many/all of the search customization options I get from desktop firefox"
Firefox Mobile 28 (the oldest version I can run on the x86 emulator) on tablet form-factor: WORKS

So google search does seem to be offering a working page to tablet users, fwiw.
with Firefox Android version number, still the same issue. No change.
One thing I've noticed while spoofing the user agent:
On some locales, not all advanced search options fit on the screen, especially in portrait mode. In Chrome, you can scroll that options bar left and right to access all options, however in Firefox, that doesn't work.
The other thing is that the search button image doesn't display correctly, but that was already mentioned in bug 921532 Comment 14.

And of course, for Firefox users search filtering is currently missing for the image search as well.
See Also: → 921532
See Also: → 1200652
It seems like the scrolling problem and search button image problem are solved.

I tried with Firefox 47-50.
On Firefox 47 and 48, the advanced options cannot be scrolled,
but it can be scrolled on 49 and 50.

The search button image is displayed correctly from Firefox 47.
> it can be scrolled on 49 and 50.

This likely mean it depends on some prefixed event listeners that we added support for (that will ship in 49).
Spoofing UA to Chrome or the Android browser restores the full menu, so yes, Google is intentionally crippling functionality on Firefox for Android. Where would be the best place to complain about this?
Karl has started a discussion with Google, so hopefully they'll send us the same content that Chrome receives soon.
See Also: → 1331823
This is a dupe of 975444.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 975444
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.