Autocompleted URL is also shown as first suggestion (duplication)

RESOLVED DUPLICATE of bug 951624

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 951624
3 years ago
3 years ago

People

(Reporter: Jesper Hansen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8466719 [details]
Locationbar showing duplicate of autocompleted suggestion

When entering, for example, github, then the autocompleted suggestion for me is github.com - the first result to go to is also github.com. 
This is completely redundant - as well as breaks already known workflow of entering a partial link, keying down then hitting enter now takes me to the front page instead of my intended page.

Noticed this when I restarted nightly that updated it to what I believe was from the 26th of July. I am however unsure which bug causes this as a lot of unification seems to be going on.


Expected result:
Skip the showing first duplicate result.
(Reporter)

Comment 1

3 years ago
Try to enter "google" into the bar.
I am willing to bet some of you use some other part of google instead of googling your google google googling. Do you want more google with that result?
Summary: Autocompleted URL is also shown first suggestion (duplication) → Autocompleted URL is also shown as first suggestion (duplication)
This is by design, to avoid confusing users about where the autoFilled entry came from.  The change will be mitigated from the habits-breakage issue by bug 951624.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951624
(In reply to Marco Bonardo [:mak] from comment #2)
>  The change will be mitigated from the habits-breakage issue by
> bug 951624.

And by that I mean the first entry will be pre-selected, so keydown will go to the second entry, pointing to the same entry as before the change.
You need to log in before you can comment on or make changes to this bug.