Bug 995091 (UnifiedComplete)

Enable Unified Autocomplete

RESOLVED FIXED in mozilla43

Status

()

Toolkit
Places
RESOLVED FIXED
3 years ago
2 months ago

People

(Reporter: mak, Unassigned)

Tracking

(Depends on: 4 bugs, Blocks: 7 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Tracking (and enabler) bug for unified autocomplete.
Unified autocomplete is a new Places autocomplete component that will replace "urlinline" and "history" (in the sense of history autocomplete) components.
It is basically a merge of the two.

The reasoning behind it it's simple, we are going to add further stuff to autocomplete results, doing that with the current splitted components would be tricky, especially for frecency merging.

Unified autocomplete is a merge of the two old components, but using more modern and maintainable code (among which promises, Task and Sqlite.jsm). It also contains Top Search providers functionality (that is the primary reason this work is happening).
(Reporter)

Updated

3 years ago
Depends on: 995092
(Reporter)

Updated

3 years ago
Depends on: 995094
(Reporter)

Updated

3 years ago
Blocks: 995095
Flags: firefox-backlog+
(Reporter)

Updated

3 years ago
Duplicate of this bug: 927018
(Reporter)

Updated

3 years ago
Blocks: 887864
No longer depends on: 887864
(Reporter)

Updated

3 years ago
Blocks: 958188
No longer depends on: 958188
(Reporter)

Updated

3 years ago
Blocks: 810930
No longer depends on: 810930
Blocks: 951624
(Reporter)

Updated

3 years ago
Depends on: 1040335
(Reporter)

Updated

3 years ago
Depends on: 1040340
(Reporter)

Updated

3 years ago
(Reporter)

Updated

3 years ago
Depends on: 1043942
(Reporter)

Updated

3 years ago
Depends on: 1045105
Depends on: 1045283
(Reporter)

Updated

3 years ago
Depends on: 1045924
(Reporter)

Updated

3 years ago
Depends on: 1046062
(Reporter)

Updated

3 years ago
Depends on: 1046074
(Reporter)

Updated

3 years ago
Depends on: 1047613

Updated

3 years ago
Blocks: 1047904
Depends on: 1048857
Depends on: 1049506
(Reporter)

Updated

3 years ago
Depends on: 1050683

Updated

3 years ago
Depends on: 1051047

Updated

3 years ago
Depends on: 1051830
(Reporter)

Updated

3 years ago
Depends on: 1045985
(Reporter)

Updated

3 years ago
Depends on: 1043923
No longer blocks: 951624
Depends on: 951624
Depends on: 1059395
Depends on: 1059846
Depends on: 1067085
Depends on: 1067602
(Reporter)

Updated

3 years ago
Depends on: 1069865
(Reporter)

Updated

3 years ago
Blocks: 1071461
(Reporter)

Updated

3 years ago
Depends on: 1067903
(Reporter)

Updated

3 years ago
Depends on: 1073243
(Reporter)

Updated

3 years ago
Blocks: 1040340
No longer depends on: 1040340
(Reporter)

Updated

3 years ago
Blocks: 1045283
No longer depends on: 1045283
(Reporter)

Updated

3 years ago
Blocks: 1059395
No longer depends on: 1059395
(Reporter)

Updated

3 years ago
Blocks: 1046074
No longer depends on: 1046074
(Reporter)

Updated

3 years ago
Depends on: 1073846
(Reporter)

Updated

3 years ago
Blocks: 1047613
No longer depends on: 1047613
(Reporter)

Updated

3 years ago
Keywords: meta

Updated

3 years ago
Depends on: 1075554

Updated

3 years ago
Depends on: 1075662
(Reporter)

Updated

3 years ago
Depends on: 1075450

Updated

3 years ago
Depends on: 1076749
(Reporter)

Updated

3 years ago
Depends on: 1075549
(Reporter)

Updated

3 years ago
Depends on: 1077369
Depends on: 1078357
(Reporter)

Updated

3 years ago
Depends on: 1079393

Updated

3 years ago
Depends on: 1080325
(Reporter)

Updated

3 years ago
Depends on: 1081297
(Reporter)

Updated

3 years ago
No longer depends on: 1079393
(Reporter)

Updated

3 years ago
Depends on: 1085374
Depends on: 1088000

Updated

3 years ago
Depends on: 1088218

Comment 2

3 years ago
Running Iceweasel 35.0a2 (with various extensions, including Classic Theme Restorer). Saw this change, thought “that's just WRONG”, headed straight for about:config, found the relevant option and switched it off.

Just for the record, I prefer the old behaviour (browser.urlbar.unifiedcomplete = false). I'm not concerned about the actual implementation; just the presence of that unwanted extra item at the top of the autocompletion list.
(Reporter)

Updated

3 years ago
Depends on: 1094567
Depends on: 1095072
(Reporter)

Updated

3 years ago
Depends on: 530209
(Reporter)

Updated

3 years ago
Depends on: 1070778, 1065191
No longer depends on: 1088000
(Reporter)

Updated

3 years ago
Depends on: 1096962
(Reporter)

Updated

3 years ago
Depends on: 1096248
(Reporter)

Updated

3 years ago
Depends on: 1097106
(Reporter)

Updated

3 years ago
No longer depends on: 1096962

Updated

3 years ago
Depends on: 1099046

Updated

3 years ago
Depends on: 1104138

Updated

3 years ago
Depends on: 1104141
(Reporter)

Updated

3 years ago
No longer depends on: 1104141
(Reporter)

Updated

3 years ago
Depends on: 1104985
(Reporter)

Updated

3 years ago
Depends on: 1105164
(Reporter)

Updated

3 years ago
Depends on: 1105244
(Reporter)

Updated

3 years ago
Depends on: 1105456
(Reporter)

Updated

3 years ago
Depends on: 1105484
(Reporter)

Updated

3 years ago
Depends on: 1104755
(Reporter)

Updated

2 years ago
Depends on: 1105385
(Reporter)

Updated

2 years ago
Depends on: 1105911
(Reporter)

Updated

2 years ago
Depends on: 1106617
(Reporter)

Updated

2 years ago
Depends on: 1107883
(Reporter)

Updated

2 years ago
Blocks: 1124238
Depends on: 1126143
(Reporter)

Updated

2 years ago
Depends on: 1105967

Updated

2 years ago
Depends on: 1159547

Updated

2 years ago
Depends on: 1163888
(Reporter)

Updated

2 years ago
Depends on: 1157952
(Reporter)

Updated

2 years ago
Depends on: 1169985
(Reporter)

Updated

2 years ago
Blocks: 1126143
No longer depends on: 1126143
(Reporter)

Updated

2 years ago
No longer depends on: 1159547
(Reporter)

Updated

2 years ago
Depends on: 1172937
(Reporter)

Updated

2 years ago
Depends on: 1173202

Updated

2 years ago
Depends on: 1175769

Updated

2 years ago
Depends on: 1176437
(Reporter)

Updated

2 years ago
Depends on: 1177895
(Reporter)

Updated

2 years ago
Blocks: 1169985
No longer depends on: 1169985
(Reporter)

Updated

2 years ago
Depends on: 1179153
(Reporter)

Updated

2 years ago
Depends on: 1180205
(Reporter)

Updated

2 years ago
Depends on: 1180375
(Reporter)

Updated

2 years ago
Depends on: 1178045
Depends on: 1185182
Depends on: 1185183

Comment 3

2 years ago
I have been testing/using Unified Autocomplete (unifiedcomplete) for several months.  I strongly prefer it to non-unified autocomplete because when the user types a keyword, the associated URL gets highlighted in the dropdown, providing a visual indication of where pressing Enter will go.  Seems essential.

Firefox 39.0 (final release) has changed Unified Autocomplete to negate much of the value of that visual feedback.  Now, when the user types a keyword, only the host of the URL appears in the dropdown, instead of the name of the Bookmark and the entire URL.  The result is that now, even with Unified Autocomplete enabled, the user has no indication of the complete URL that will be requested when they press Enter.  The user always needs to know the exact URL that will be loaded when they press Enter.
(Reporter)

Updated

2 years ago
Depends on: 1188688
(Reporter)

Updated

2 years ago
Depends on: 1190368
Depends on: 1190366
(Reporter)

Updated

2 years ago
Depends on: 1187753

Updated

2 years ago
Depends on: 1187653
(Reporter)

Updated

2 years ago
Depends on: 1192218

Updated

2 years ago
No longer depends on: 1192218

Updated

2 years ago
Depends on: 1192769

Updated

2 years ago
Depends on: 1196849

Updated

2 years ago
Depends on: 1196874
(Reporter)

Updated

2 years ago
No longer depends on: 1196874
(Reporter)

Updated

2 years ago
No longer depends on: 1196849
(Reporter)

Updated

2 years ago
No longer depends on: 1187653
(Reporter)

Updated

2 years ago
No longer depends on: 1178045
(Reporter)

Updated

2 years ago
No longer depends on: 1175769
(Reporter)

Updated

2 years ago
No longer depends on: 1104755
(Reporter)

Updated

2 years ago
No longer depends on: 1192769

Updated

2 years ago
Depends on: 1198683

Updated

2 years ago
Depends on: 1198687

Updated

2 years ago
No longer depends on: 1198687

Updated

2 years ago
No longer depends on: 1198683
(Reporter)

Updated

2 years ago
No longer depends on: 1177895
(Reporter)

Comment 4

2 years ago
There are no more P1 blockers to the feature, we can ship it. Remaining bugs will be fixed apart.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43

Updated

a year ago
Blocks: 1235482

Updated

a year ago
Blocks: 1235645

Updated

a year ago
Depends on: 1235891

Updated

a year ago
Depends on: 1237750

Updated

7 months ago
Depends on: 1309354

Updated

2 months ago
Depends on: 1346409

Updated

2 months ago
Depends on: 1346416

Updated

2 months ago
Depends on: 1346428
You need to log in before you can comment on or make changes to this bug.