Closed Bug 1048012 Opened 6 years ago Closed 4 years ago

Provide a better error handling instead of |NS_RUNTIMEABORT("OOM")| introduced in Bug 950076

Categories

(Core :: DOM: Core & HTML, defect)

31 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1167189

People

(Reporter: Dexter, Unassigned)

Details

Bug 950076 introduced a few |NS_RUNTIMEABORT("OOM")| to handle out of memory situations (See https://bugzilla.mozilla.org/attachment.cgi?id=8394385).

As highlighted in Bug 1037214, those aborts should either be handled or replaced with NS_ABORT_OOM(size).
Errata: as mentioned by :jst in bug 950076 comment 22, |NS_RUNTIMEABORT("OOM")| should be kept in nsXBLPrototypeBinding.cpp.
That one should probably be NS_ABORT_OOM, now that we have it. It produces better crash-stats results.
Hi Alessio, I am also interested in taking this on. Please advise
Flags: needinfo?(alessio.placitelli)
Is this also a mentored bug?
No Patrick, this isn't a mentored bug.
Flags: needinfo?(alessio.placitelli)
Bug 1167189 replaced NS_RUNTIMEABORT("OOM") with NS_ABORT_OOM(0) in Firefox 39.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1167189
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.