Search suggestion box doesn't follow the search bar when resizing the browser

RESOLVED DUPLICATE of bug 1159672

Status

()

P3
normal
Rank:
32
RESOLVED DUPLICATE of bug 1159672
4 years ago
3 years ago

People

(Reporter: petruta.rasa, Unassigned)

Tracking

(Depends on: 1 bug)

34 Branch
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ux bug][fxsearch])

Attachments

(1 attachment)

Created attachment 8467024 [details]
WrongPositionPanel.png

Reproducible on Nightly 34.0a1 20140803030203:
Mozilla/5.0 (X11; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

Steps to reproduce:
1. Open Firefox 
2. On about:home page enter some string in the search bar - search suggestions are displayed
3. Resize the browser, maximize it, enter full screen etc 
4. Repeat these steps on the about:newtab page

Actual results:
Search suggestion box is moved on the screen, it's position doesn't remain fixed to the search bar

Expected results:
Search suggestions box should either close when resizing the browser (such as Australis panel and icons), either stick to the search bar
No longer blocks: 612453
Depends on: 612453

Comment 1

4 years ago
Hiding the suggestions when resizing the browser sounds like a good and easy way to fix this.  Making the popup a real autocomplete popup would be even better...
Flags: firefox-backlog+

Comment 2

4 years ago
Bug 1066787 will make these suggestions use the standard toolkit/XUL autocomplete popup.
Blocks: 612453
Depends on: 1066787
No longer depends on: 612453

Updated

4 years ago
Rank: 32
Flags: qe-verify+
Priority: -- → P3
Whiteboard: [ux bug][fxsearch]

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1159672
You need to log in before you can comment on or make changes to this bug.