Version 31.0 Autocomplete hangs for 15 to 30 seconds

RESOLVED DUPLICATE of bug 984875

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 984875
4 years ago
3 years ago

People

(Reporter: F16JetJock, Unassigned)

Tracking

({regression})

31 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Subsequent to selecting "Write" button, 80% of the time after typing one digit into the TO" address space, Thunderbird 31.0 pauses (with rotating-doughnut displayed). for 15 to 30 seconds before autocomplete populates address field or before a manual address can be filled-in. Never has this anomaly occurred in any previous Thunderbird version.


Actual results:

After typing first digit into "TO" address field, Thunderbird 31.0 pauses (freezes) for 15 to 30 seconds before address field is or can be filled in.


Expected results:

Autocomplete completes filling-in an Address Book address within a few milliseconds. Or, in manual, continuous typing in the "To" address space is permitted immediately.

System is W7-64bit, 16Gig RAM, 2Tb HDD
(Reporter)

Comment 1

4 years ago
System is W7-64bit, 16Gig RAM, 2Tb HDD

Comment 2

4 years ago
Hi, 
The name you started typing email id is in Personal or Collected Address book?

Did you tried with your email ID?

Check in safemode.

If you using Any Addons for Contact SYNC, it may be happen

Updated

4 years ago
Duplicate of this bug: 1047833

Comment 4

4 years ago
This is a very serious bug. Why has it not been assigned to anyone at Mozilla? Thanks.

Comment 5

4 years ago
Do you happen to have a very large address book?
Tb31 searches more fields (and uses contains instead of beginswith) so that could be the problem...
Keywords: regression
(Reporter)

Comment 6

4 years ago
The size of the Address Book is should not be a factor since all previous versions of Thunderbird, including the most recent, 24.6.0, did not have this problem.
(Reporter)

Comment 7

4 years ago
Additionally, when multiple Address Book selections are made (even ten or perhaps twenty), the "To" address fields all populate within milliseconds, which is normal for all previous TB versions.

Comment 8

4 years ago
What do you mean by "multiple Address Book selections" ?

I ask the size (roughly how many contacts) because as I said, more fields are searched and in a more expensive manner.
(Reporter)

Comment 9

4 years ago
I mean to "broadcast" to multiple destinations:

When I select "Write", my Address Book index appears on the left. To perform a broadcast, I just hold down keyboard Control button, select left-click the addresses I wish to broadcast to, choose which "Add" button, and then the address lines immediately populate in vertical order with the selected address.

Comment 10

4 years ago
(In reply to F16JetJock from comment #9)
> When I select "Write", my Address Book index appears on the left. To perform
> a broadcast, I just hold down keyboard Control button, select left-click the
> addresses I wish to broadcast to, choose which "Add" button, and then the
> address lines immediately populate in vertical order with the selected
> address.

OK and how does this relate to autocomplete?
(Reporter)

Comment 11

4 years ago
Please read original explanation of problem.

When broadcasting, TB 31.0 populates address lines in milliseconds as normal. Only when manually typing in address does the hanging occur.

Updated

4 years ago
Duplicate of this bug: 1046333

Updated

4 years ago
Duplicate of this bug: 1046887

Updated

4 years ago
Duplicate of this bug: 1046648

Comment 15

4 years ago
This does appear to be a widespread complaint with TB31, at least in the support forum.  And the delay is quite noticeable.  I have been seeing it to some degree since around the same time I saw the new remote image buttons appear,  but I have no idea if there is a relationship.

I did have hundreds of duplicates in three address books managed by the Google Contacts add-on and deleting those did improve things quite a bit.  But there is still a noticeable delay.

Is there a pref to revert to the old way of doing things to test if the change is the cause?
(Reporter)

Comment 16

4 years ago
I would have already returned to using TB 24.6.1 were it not for the Lightning calendar abandoning the latter.

Comment 17

4 years ago
So how many contacts do we talk here?

F16JetJock, do you also use the Google contacts addon?

Comment 18

4 years ago
(In reply to :aceman from comment #17)
> So how many contacts do we talk here?
> 
> F16JetJock, do you also use the Google contacts addon?

It is not the add-on aceman. At least not just that.  I have been through that in the support forums with a number of complainants.

I have 17 address books.  but there are probably only a few hundred across all of them.

I just deleted a few address books (most of them have been created to support other folk) and restarted and the address completion is faster.

Comment 19

4 years ago
I just noticed bug 984875 (which tries to fix this slow autocomplete) didn't make it into TB31. We could think about backporting it to TB31.1 if any of you guys test it out (in TB32 beta) and report that it does fix the problem for you.

Comment 20

4 years ago
@ wayne,  You were concerned about this re the throttling of 31.  Perhaps acemans comment is relevant to that.

@ Aceman  I am using daily builds,  so I guess I have been testing it all along.

Comment 21

4 years ago
(In reply to Matt from comment #20)
> @ Aceman  I am using daily builds,  so I guess I have been testing it all
> along.

So does that mean daily is slow too and bug 984875 didn't help?

Comment 22

4 years ago
It means I have had issues that were not related to this or bug 984875.

since my last post I have been looking and checking.

I created a couple of address books and populated them with a couple of thousand email addresses and re-deleted the address books that originally caused issues.

My view is Bug 984875 is a fix.
The add-on is a separate issue which has muddied the waters in my case.  I can now almost instantaneously get an auto fill list with a dozen address books and thousands of contacts.

Comment 23

4 years ago
(In reply to :aceman from comment #17)
> So how many contacts do we talk here?
> 
> F16JetJock, do you also use the Google contacts addon?
Flags: needinfo?(randy)

Comment 24

4 years ago
(In reply to Matt from comment #20)
> @ wayne,  You were concerned about this re the throttling of 31.  Perhaps
> acemans comment is relevant to that.

Yes, IMO bug 984875 should be backported to TB31.1, assuming it helps you and F16JetJock.  TB32 which contains the patch isn't yet available as beta. So you will need to test with TB33 https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-earlybird/
(Reporter)

Comment 25

4 years ago
I do not use the Google Contact add-on.
Flags: needinfo?(randy)
(Reporter)

Comment 26

4 years ago
I have perhaps 1000 contacts distributed amongst fifteen address books except for Collected Addresses which has ALL addresses. For all versions up to TB 24.6.1, the address field would normally populate (or a selection of addresses to choose from) within about 500ms.
(In reply to F16JetJock from comment #11)
> Please read original explanation of problem.
> 
> When broadcasting, TB 31.0 populates address lines in milliseconds as
> normal. Only when manually typing in address does the hanging occur.

F16JetJock, thanks for explaining. Populating the recipient area with many contacts from contacts side bar search results is technically an entirely different story compared to typing in recipient area which will trigger recipient autocomplete search. When you populate from the side bar, the search is already done because you're just dragging results, so that's obviously faster.

It would be interesting to compare the time needed for search in side bar vs. search via recipient autocomplete, but we can't really do that yet because side bar searches *foo bar* whereas autocomplete searches *foo* AND *bar*, plus it's differently coded, so it's really apples and pears.

Comment 28

4 years ago
https://support.mozilla.org/en-US/questions/1013192?utm_campaign=questions-reply&utm_medium=email&utm_source=notification

This user reports being happy with the result using daily,  so I think the issue is back porting the fix in Bug 984875

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 984875
You need to log in before you can comment on or make changes to this bug.