Closed Bug 1048375 Opened 6 years ago Closed 6 years ago

browser_aboutHome.js intermittently causes external requests to snippets.mozilla.com

Categories

(Firefox :: General, defect)

defect
Not set
normal
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 34
Iteration:
34.2
Tracking Status
firefox32 --- fixed
firefox33 --- fixed
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- fixed

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file)

With the patch from bug 1029148 applied, this is intermittent locally, but failing consistently on the try server (https://tbpl.mozilla.org/?tree=Try&rev=7930d58a0081).

AboutHomeUtils.snippetsURL is a lazy getter, so if it's called for the first time before the test has started and changed the value of the pref, the test causes external network requests.
Flags: firefox-backlog+
Attached patch PatchSplinter Review
Try is looking green: https://tbpl.mozilla.org/?tree=Try&rev=36da47545266 (but no Windows results yet).
Attachment #8467173 - Flags: review?(gavin.sharp)
Iteration: --- → 34.1
OS: Mac OS X → All
Hardware: x86 → All
Attachment #8467173 - Flags: review?(gavin.sharp) → review+
Status: NEW → ASSIGNED
QA Whiteboard: [qa?]
QA Whiteboard: [qa?] → [qa-]
Iteration: 34.1 → 34.2
https://hg.mozilla.org/mozilla-central/rev/5d3084f4f861
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Duplicate of this bug: 1036028
You need to log in before you can comment on or make changes to this bug.