Closed Bug 1048419 Opened 6 years ago Closed 4 years ago

Advanced fonts settings dialog takes up to one second to open from about:preferences

Categories

(Firefox :: Preferences, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ge3k0s, Unassigned)

References

Details

When you try to open the advanced subdialog in content pane (in-content preferences) it takes up to one second to show itself so it doesn't feel smooth at all. AFAIR when the dialog was first converted to in-content it worked just fine but since the new styling (bug 1038288) was applied it feels a lot more laggy.
Blocks: 1038288
I don't see this delay. Also tried in my XP VM where no fast graphic card is used and it appears immediately.

Or did you mean the Fonts dialog? Here it has a slight delay but it is the same when opening the dialog in old prefs.
Yes I'm talking about the fonts advanced dialog. I remember having this dialog opening quicker (even in-content) but before the new styling. It's strange.
Summary: Advanced subdialog in content pane takes up to one second to open → Advanced fonts settings dialog takes up to one second to open from about:preferences
So I've tested a previous version and the lag was indeed already there. It would be nice to eliminate it though so I will let this bug open.
Blocks: 752197
No longer blocks: 1038288
Depends on: 1124416
Ok I've tried opening the dialog again recently and it doesn't seem so bad. Closing for now.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.