Address auto-completion interacting [badly!] with type-ahead

RESOLVED DUPLICATE of bug 1012397

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1012397
4 years ago
4 years ago

People

(Reporter: Beau James, Unassigned)

Tracking

({regression})

31 Branch
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8467321 [details]
Thunderbird v31 address autocomplete -screen clips with comments

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Start a new message. Input cursor & focus is on the first email address entry line.

Type enough characters to identify an address that will autocomplete. Type quickly and end with an <Enter> - don't wait for the autocompletion to be displayed in the UI.




Actual results:

The address field contains only the characters that you typed - usually, an invalid or incomplete email address. On some occasions, the address field contains the WRONG email address!


Expected results:

Autocompletion should have filled in the expected match result.

This is a major regression in UI behavior that occurred after TB v29. Up through v29, the address autocompletion process was completed before the <Enter> was consumed. This was extremely desirable - users could type enough characters that they know will autocomplete with the desired address, hit <Enter>, and keep typing. The right results happened, even when TB is lagging behind the user (high CPU load on PC, virtual memory / paging delay, etc.). Users have long been conditioned to expect this 'correct' behavior.

Now, the user is forced to wait and carefully watch the UI on the screen to verify that the correct results occur. If not, autocompletion may not run at all. Worse, autocompletion may run on only the first portion of the characters that the user typed, come up with the *wrong* address match, and put that wrong address into the address field.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1012397
You need to log in before you can comment on or make changes to this bug.