If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

L10n builds broken on comm-central (34.0a1 builds)

RESOLVED FIXED in Thunderbird 36.0

Status

MailNews Core
Build Config
--
blocker
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: ewong)

Tracking

({regression})

Trunk
Thunderbird 36.0
regression

Thunderbird Tracking Flags

(thunderbird34 fixed, thunderbird35 fixed, thunderbird36 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Since the most recent bustage, l10n builds are broken:

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014-08-05-03-02-40-comm-central-l10n/comm-central-linux-l10n-nightly-cs-bm77-build1-build2193.txt.gz

make[1]: Entering directory `/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/config'
/tools/gcc-4.7.3-0moz1/bin/gcc -m32 -march=pentiumpro -o host_nsinstall.o -c -DXP_UNIX -MD -MP -MF .deps/host_nsinstall.o.pp -O3  -DUNICODE -D_UNICODE -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/mozilla/config -I.  -I../dist/include  -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/dist/include/nspr -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/dist/include/nss      -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/dist/include/nspr /builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/mozilla/config/nsinstall.c
host_pathsub.o
/tools/gcc-4.7.3-0moz1/bin/gcc -m32 -march=pentiumpro -o host_pathsub.o -c -DXP_UNIX -MD -MP -MF .deps/host_pathsub.o.pp -O3  -DUNICODE -D_UNICODE -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/mozilla/config -I.  -I../dist/include  -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/dist/include/nspr -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/dist/include/nss      -I/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/dist/include/nspr /builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/mozilla/config/pathsub.c
make[1]: *** No rule to make target `../build/unix/stdc++compat/libhost_stdc++compat.a', needed by `nsinstall_real'.  Stop.
make[1]: Leaving directory `/builds/slave/tb-c-cen-lx-l10n-ntly-00000000/build/comm-central/objdir-tb/mozilla/config'

Updated

3 years ago
Keywords: regression
(Assignee)

Comment 1

3 years ago
SeaMonkey's l10n builds have been broken for quite some time because of this.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1083677
(Assignee)

Updated

3 years ago
Component: Build Config → Build Config
Product: Thunderbird → MailNews Core
(Assignee)

Comment 3

3 years ago
(In reply to Edmund Wong (:ewong) from comment #1)
> SeaMonkey's l10n builds have been broken for quite some time because of this.

Furthermore it's also blocking SeaMonkey 2.31b1 repacks.
Severity: normal → blocker
(Assignee)

Comment 4

3 years ago
Standard8, I'm looking at the mail/ code and aside for two linux64 l10n mozconfigs,
the rest already have the --disable-stdcxx-compat flag set.

Is TB still encountering this?  I'm guessing it could've been
fixed by http://hg.mozilla.org/releases/comm-beta/rev/c8f5d9af8549
Flags: needinfo?(standard8)
(Assignee)

Comment 5

3 years ago
Created attachment 8508525 [details] [diff] [review]
fix l10n mozconfigs. (v1)
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8508525 - Flags: review?(Pidgeot18)
(Reporter)

Comment 6

3 years ago
Comment on attachment 8508525 [details] [diff] [review]
fix l10n mozconfigs. (v1)

Its conceivable we haven't done a release with the bits that were broken in since this was fixed. So just adding it is the right thing to do I think.

Please get this onto aurora/beta as well.
Flags: needinfo?(standard8)
Attachment #8508525 - Flags: review?(Pidgeot18)
Attachment #8508525 - Flags: review+
Attachment #8508525 - Flags: approval-comm-beta+
Attachment #8508525 - Flags: approval-comm-aurora+
(Assignee)

Comment 7

3 years ago
(In reply to Mark Banner (:standard8) (away until 23rd Oct) from comment #6)
> Comment on attachment 8508525 [details] [diff] [review]
> fix l10n mozconfigs. (v1)
> 
> Its conceivable we haven't done a release with the bits that were broken in
> since this was fixed. So just adding it is the right thing to do I think.
> 
> Please get this onto aurora/beta as well.

Thanks!
(Assignee)

Comment 8

3 years ago
Comment on attachment 8508525 [details] [diff] [review]
fix l10n mozconfigs. (v1)

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/5686cf2b4cad
(Assignee)

Comment 9

3 years ago
Comment on attachment 8508525 [details] [diff] [review]
fix l10n mozconfigs. (v1)

Pushed to comm-aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/5f378a1aa24c

Pushed to comm-beta:
https://hg.mozilla.org/releases/comm-beta/rev/d22cbdff2a6f
(Reporter)

Updated

3 years ago
status-thunderbird34: --- → fixed
status-thunderbird35: --- → fixed
Target Milestone: --- → Thunderbird 36.0
Blocks: 1049443
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
status-thunderbird36: --- → fixed
You need to log in before you can comment on or make changes to this bug.