Closed Bug 1049443 Opened 6 years ago Closed 6 years ago

Lightning 3.3: cannot convert email to event [Faulty extraction pattern][SyntaxError: invalid range in character class] reported by calExtract.jsm

Categories

(Mozilla Localizations :: zh-TW / Chinese (Traditional), defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: fangchen, Assigned: petercpg)

References

Details

Attachments

(3 files)

Attached file ERROR.txt
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I update my THUNDERBIRD to 31.0,and update
 lightning to 3.3. 


Actual results:

When I select a mail,and try to convert it to a event, no thing happen. I have reinstalled my thunderbird and lightning, but no use. when I click the  button "new event",it can work and pop up a window.



Expected results:

It should pop up a new event window.
I check the error message,it looks like the attach file
Duplicate of this bug: 1049445
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 31 → Lightning 3.3
Hi, what localization of Thunderbird and Lightning do you use?
Summary: THUNDERBIRD 31.0+lightning 3.3 cannot transfer email to event → cannot convert email to event [Faulty extraction pattern][SyntaxError: invalid range in character class] reported by calExtract.jsm
> Hi, what localization of Thunderbird and Lightning do you use?

I use the chinese vision of TB,and lightning does not have option,i think it should be english.(In reply to Stefan Sitter from comment #2)
I have this issue too, after upgraded TB from 24 to 31.1.1 with Lightning 3.3.
I use English localization of Thunderbird and Lightning, on a Chinese version WindowsXP.
Starting TB with Applocale set to English gives same errors.
There are two messages on the error console:

Timestamp: 2014-9-23 9:48:08
Error: [calExtract] Faulty extraction pattern 從 %1$S 時 | 從 %1$S 點 | %1$S - | %1$S ~ | %1$S 點到 | %1$S 時到 | %1$S 點至 | %1$S 時至 | for from.hour
Source File: resource://calendar/modules/calExtract.jsm
Line: 1114

Timestamp: 2014-9-23 9:48:08
Error: SyntaxError: invalid range in character class
Source File: resource://calendar/modules/calExtract.jsm
Line: 1183
Good news! I find the error has been fixed. I do not know whitch is the reason,because I updated my thunderbird to the newest 31.1.2,and the ligiting to 3.3.1 . But I DO BELIEVE, the lighting 's update fix the error.
(In reply to fangchen from comment #5)
> Good news! I find the error has been fixed. I do not know whitch is the
> reason,because I updated my thunderbird to the newest 31.1.2,and the
> ligiting to 3.3.1 . But I DO BELIEVE, the lighting 's update fix the error.

I can confirm this. So you could change the bug status to "fixed".
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
FYI, I don't think the error is fixed. Because of another error (bug 1072815) the Chinese translation is missing in Lightning 3.3.1. Once Chinese is added back this error might occur again.
Is this a localization error, or an error in the extractor?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Merike, could you help to answer if this is problem with calExtract or the localization?
Flags: needinfo?(gasell+mozilla)
(In reply to Lu Wei from comment #4)
> Error: [calExtract] Faulty extraction pattern 從 %1$S 時 | 從 %1$S 點 | %1$S - |
> %1$S ~ | %1$S 點到 | %1$S 時到 | %1$S 點至 | %1$S 時至 | for from.hour

This one is an error in localization and should be reported to the localizer. | should be removed from the end.

Extraction splits patterns based on | characters and if a pattern starts or ends with | then as a result it would try to search empty strings which would make no sense. If I remember correctly it used to result in an infinite loop before I added this check.
Flags: needinfo?(gasell+mozilla)
Assignee: nobody → shaohua.wen
Blocks: 1072815
Component: General → zh-CN / Chinese (Simplified)
Product: Calendar → Mozilla Localizations
QA Contact: shaohua.wen
Summary: cannot convert email to event [Faulty extraction pattern][SyntaxError: invalid range in character class] reported by calExtract.jsm → Lightning 3.3: cannot convert email to event [Faulty extraction pattern][SyntaxError: invalid range in character class] reported by calExtract.jsm
Version: Lightning 3.3 → unspecified
I just pushed rev af436190bca5 to fix this problem in zh-TW builds, it might take some time to have a testing build.
Seem not for zh-CN.
Assignee: shaohua.wen → petercpg
Component: zh-CN / Chinese (Simplified) → zh-TW / Chinese (Traditional)
QA Contact: shaohua.wen → petercpg
Philipp, it seems Win32 nightlies are not building, or there are more problems?
Flags: needinfo?(philipp)
There is bug 1048872, I believe l10n builds are generally broken right now. Sorry about that :-/
Depends on: 1048872
Flags: needinfo?(philipp)
(In reply to Philipp Kewisch [:Fallen] from comment #14)
> There is bug 1048872, I believe l10n builds are generally broken right now.
> Sorry about that :-/

Fallen, is this fixed now?  I'm marking bug 1048872 as 'fixed'.
Flags: needinfo?(philipp)
Deferring ni? to Peter, please confirm this is actually fixed with working l10n builds. Thanks!
Flags: needinfo?(philipp) → needinfo?(petercpg)
Other errors are gone, but SyntaxError: invalid range in character class still exists for line 1184. Could it be more problems in elsewhere?

By the way I spotted the initial date after loading Lightning became 5555/01/10, it goes the correct date clicking the circle (Today) button. Is this also related to this bug?
Flags: needinfo?(petercpg)
After I update lighting to 3.3.3,this bug appears again. And now I have to use the version 3.3.1,which only displays in EN.
If I'm reading changesets and dashboard right then it seems that pattern fixes for zh-TW are present on release branch but the signed off revision for Thunderbird 31 (and Lightning 3.3) is from July. So 3.3.3 includes old strings due to missing signoff. It also looks like this branch is closed for further signoffs.

Philipp, how can zh-TW revision be updated for release channel?
Flags: needinfo?(philipp)
There is no official way to update the locales, sign-offs for the 3.3.x branch are closed. I can however do manual repacks and release a 3.3.4 with it. If you can point me to the changesets that need to be included, I can apply them to 3.3.3.
Flags: needinfo?(philipp)
Duplicate of this bug: 1138014
Fallen, the latest changeset for -release repo should be this for calendar in zh-TW: http://hg.mozilla.org/releases/l10n/mozilla-release/zh-TW/file/31beb499d946/calendar/

I've also committed some changes to calendar-extract.properties but not yet decided to uplift it, fangchen, could you also test this function again in Thunderbird 38a2 with Lightning 4.0a2 to see it's all right?
Flags: needinfo?(fangchen)
Manually uplifted rule update to beta: http://hg.mozilla.org/releases/l10n/mozilla-beta/zh-TW/rev/c0d9cd844bea . However, this bug should be already fixed in changeset c2ac0ff6e9ad.

I'm marking this bug as fixed, as I tested on multiple aurora and nightly builds, please reopen if there's more problem occurred. (The weird 5555 year bug seems gone now.)

ni Fallen to see if it's possible to do manual repacks to 3.3.x. Thanks.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(fangchen) → needinfo?(philipp)
Resolution: --- → FIXED
I've tested that changeset against 3.3.x, unfortunately it does not match. The current l10n/mozilla-beta is meant for 3.9b1 so there are obviously differences to 3.3.x. The next thing I tried is to the the signed-off changeset for Thunderbird 31 and apply the changeset you mentioned on it. One chunk fails when applying the patch.

What I essentially need is a patch I can apply on top of changeset 5710f029fd6a that fixes this bug.
Flags: needinfo?(philipp) → needinfo?(petercpg)
Duplicate of this bug: 1147708
Attached patch bug1049443.patchSplinter Review
Fix empty matches in the end of line. This patch should do the trick.
Flags: needinfo?(petercpg)
Attachment #8583640 - Flags: review?(philipp)
(In reply to Merike (:merike) from comment #10)
> (In reply to Lu Wei from comment #4)
> > Error: [calExtract] Faulty extraction pattern 從 %1$S 時 | 從 %1$S 點 | %1$S - |
> > %1$S ~ | %1$S 點到 | %1$S 時到 | %1$S 點至 | %1$S 時至 | for from.hour
> 
> This one is an error in localization and should be reported to the
> localizer. | should be removed from the end.
> 
> Extraction splits patterns based on | characters and if a pattern starts or
> ends with | then as a result it would try to search empty strings which
> would make no sense. If I remember correctly it used to result in an
> infinite loop before I added this check.

I am now on TB 31.5.0 and Lightning 3.3.3 (both en-US version), the bug still exists. So I think it is not an error in localized version, but in the TB or Lightning to read localization information.
I should add that I cannot determine whether Lightning 3.3.3 is en-US version or not; I installed it inside en-US version TB. And changing my WindowsXP system region setting do not help. I am confused.
I tried to roll back to Lightning 3.3.1, and "convert to" context is greyed out! What happened to this version? It used to work!
(In reply to Lu Wei from comment #30)
> I tried to roll back to Lightning 3.3.1, and "convert to" context is greyed
> out! What happened to this version? It used to work!
Disabled menu entry under 3.3 series could be bug 1142707. If you see it under other circumstances please file a new bug.
Yes, tried again after selecting message works. Thank you.
Flags: needinfo?(petercpg)
Attachment #8583640 - Flags: review?(philipp) → review+
(In reply to Philipp Kewisch [:Fallen] from comment #33)
> Heya, sorry for the delay. Please test these builds and let me know if it
> works:
> 
> http://mozilla.kewis.ch/ltn334/lightning-linux.xpi
> http://mozilla.kewis.ch/ltn334/lightning-mac.xpi
> http://mozilla.kewis.ch/ltn334/lightning-win32.xpi

Tested on Tb 31.6 with win32 build, for most mail it doesn't convert, and still raise a "SyntaxError: invalid range in character class" error on Line 1183. But for my some 1 or 2 mails it worked without error. 

Lightning 4.2a1 on Tb 40.0a1 has no such issue. Probably another unreported bug, since 3.3 is already releases, do we need to track this issue?
Flags: needinfo?(petercpg)
Merike, any ideas on this?
Flags: needinfo?(gasell+mozilla)
Line 1183 is bug 1121156. Fixed in 4.0 but not in earlier versions. It's probably a good idea to test on beta to make sure localization itself works well with various emails.
Flags: needinfo?(gasell+mozilla)
Looks good now on Beta. Some mails were extracted with wrong times, but the dialog is working at least.
Status: RESOLVED → VERIFIED
I am running TB 38.01, Lightning 4.0.0.1 and I am seeing something that likes like this. I get some event confirmations as emails that until recently Lightning correctly converted to events, picking the dates out of the emails. Now, the events get created with the current date and a time close to current time. Not sure what the last combination of versions was that it all worked on as there was a period when I didn't get the emails. If it helps, the Lightning date format is set to "Long: 18 June 2015" (UK style). The format of the date / time in the emails is "21 June 2015 at 09:30 for 45mins". Running on Windows 7, locale set to English (UK)
(In reply to keithc from comment #38)
> I am running TB 38.01, Lightning 4.0.0.1 and I am seeing something that
> likes like this. I get some event confirmations as emails that until
> recently Lightning correctly converted to events, picking the dates out of
> the emails. Now, the events get created with the current date and a time
> close to current time.
I think you may be running into bug 1176936. Could you try downloading Lightning manually from https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/?page=1#version-4.0.0.1, installing it in addon manager, restarting Thunderbird and converting after that? If I'm correct it'll work as a workaround.

If it still does not work I'd appreciate if you could file a new bug here so that we would not spam old bug that is already fixed.
(In reply to Merike (:merike) from comment #39)
> (In reply to keithc from comment #38)
> > I am running TB 38.01, Lightning 4.0.0.1 and I am seeing something that
> > likes like this. I get some event confirmations as emails that until
> > recently Lightning correctly converted to events, picking the dates out of
> > the emails. Now, the events get created with the current date and a time
> > close to current time.
> I think you may be running into bug 1176936. Could you try downloading
> Lightning manually from
> https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/
> ?page=1#version-4.0.0.1, installing it in addon manager, restarting
> Thunderbird and converting after that? If I'm correct it'll work as a
> workaround.
> 
> If it still does not work I'd appreciate if you could file a new bug here so
> that we would not spam old bug that is already fixed.

The workaround worked, thanks. Strange, as it seems I was already using the same version of Lightning.
You need to log in before you can comment on or make changes to this bug.