Closed Bug 1048994 Opened 8 years ago Closed 8 years ago

[FxA] FxA signup/login screen displays contents incorrectly when you go away from & back to it (including "{{tos}}" and "{{pn}}" and "Terms of ServicePrivacy Notice")

Categories

(Firefox OS Graveyard :: FxA, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S2 (15aug)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: njpark, Assigned: jhirsch)

References

Details

Attachments

(3 files)

Attached image 2014-08-05-11-55-38.png
STR:
Enter FTE, and on Firefox Accounts page, press 'Create Account or Sign in'
Enter e-mail address, press next
Intstead of entering password, press Back button.

Expected:
the previous page displays normally.
Actual:
The tags are shown  (check attachment)

This does not happen in 2.1, only happens in 2.0.

Version Info:
Gaia      597975839c04e0198eb98c2c77474f057b5531e7
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ddeead927143
BuildID   20140805000238
Version   32.0
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
[Blocking Requested - why for this release]:

Terrible UX bug, see screenshot
Assignee: nobody → 6a68
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → 2.0+
Duplicate of this bug: 1050917
This is not specific to FTE -- this happens if you launch the Firefox Accounts UI from Settings as well, as described in bug 1050917.

(dropping "FTE" from summary, and extending summary a bit to make this bug more searchable)
Summary: [FTE][FxA] During FTE, FxA signup screen displays contents incorrectly → [FxA] FxA signup/login screen displays contents incorrectly when you go away from & back to it (including "{{tos}}" and "{{pn}}" and "Terms of ServicePrivacy Notice")
Pretty interesting that this didn't show up in 2.1. I'm guessing it's because some l10n.js changes were not uplifted to 2.0. Investigating now.
Stas, any idea why this would happen only on 2.0? Are there any l10n.js changes that we could easily backport to 2.0 to fix this? I see quite a few changes that haven't been uplifted, do you happen to know if any of these could be the missing diff?
Flags: needinfo?(stas)
Whoops, looks like stas is on vacation. :gandalf, any thoughts?
Flags: needinfo?(stas) → needinfo?(gandalf)
Whoops again, the answer's rather simpler than that: just need to remove the data-10n-id from that element.
Attached file Github PR 22851
Hi Fernando - One more 2.0 blocker, if you have time :-)

Looks like the problem here only surfaces in 2.0, I'm not exactly sure what changed in l10n.js, but both 2.1 and 2.0 work if we just remove the data-l10n-id from the affected div.

Since I localize that paragraph manually, the data-l10n-id isn't used anyway.

Thanks!

Jared
Attachment #8472624 - Flags: review?(ferjmoreno)
Jared: where do you localize the paragraph manually and why? :) I'd prefer to use data-l10n-id over mozL10n.get if possible :)
Hey Zibi,

The problem is that this paragraph contains placeholders that need to be replaced with html, so l10n.js couldn't do it for me (the default behavior is to shift existing nodes to the end of the string, and I couldn't use it to insert nodes, as it uses textContent, not innerHTML, to replace placeholders).

I think it would be fantastic if l10n.js supported this use case for 2.1+, as I've had to do manual replacements in a number of spots.

For this particular example, see [1] for the strings, and [2] for the code.

Cheers,

Jared

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/fxa/locales/fxa.en-US.properties#L62-L68
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/fxa/js/screens/fxam_enter_email.js#L65-L75
oh, ok. yeah, we're going to support it in the future (entity reference from inside of another entity), but that's out of scope for 2.1. Thanks for the explanation!
QA Whiteboard: [2.0-signoff-need]
(In reply to Zibi Braniecki [:gandalf] from comment #11)
> oh, ok. yeah, we're going to support it in the future (entity reference from
> inside of another entity), but that's out of scope for 2.1. Thanks for the
> explanation!

Sure! Glad to hear it's on your roadmap for a future release :-)
QA Whiteboard: [2.0-signoff-need] → [2.0-signoff-need+]
Attachment #8472624 - Flags: review?(ferjmoreno) → review+
Thanks, Fernando!

Master: https://github.com/mozilla-b2g/gaia/commit/af90f3cbad4ecc4801ae0516670a46084672f6bd
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S2 (15aug)
This issue has been verified successfully on Flame 2.0,2.1

See attachment: Verify_video.3gp
Reproducing rate: 0/5
Flame 2.0 build:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141208000206
Version         32.0
Flame2.1 build:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Status: RESOLVED → VERIFIED
Attached video Verify_video.3gp
You need to log in before you can comment on or make changes to this bug.