{HTML4} Line breaks immediately before end tags not ignored

VERIFIED DUPLICATE of bug 2750

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 2750
19 years ago
2 years ago

People

(Reporter: Sam Allen, Assigned: buster)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE])

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
The following two HTML fragments should render exactly the same.

<a href="">My favorite Website</a>

<a href="">
My favorite Website
</a>

Mozilla does not correctly ignore the line break immediately before the end tag
(the underline continues out one space more than it should).

The relevant section of HTML 4.0 is:

http://www.w3.org/TR/REC-html40/appendix/notes.html#h-B.3.1
(Reporter)

Comment 1

19 years ago
Created attachment 990 [details]
Demonstrates problem (document is HTML4.0 strict)

Updated

19 years ago
Assignee: rickg → kipp

Comment 2

19 years ago
Kipp -- FYI. The parser doesn't drop newlines because it can't determine the CSS
context in which they'll be rendered.

Updated

19 years ago
Whiteboard: [TESTCASE] klein_sh@inter.net.il

Comment 3

19 years ago
Created attachment 1111 [details]
Test Case for 10490 Bug
(Reporter)

Updated

19 years ago
Summary: Line breaks immediately before end tags not ignored → {HTML4} Line breaks immediately before end tags not ignored
Whiteboard: [TESTCASE] klein_sh@inter.net.il → [TESTCASE]
(Reporter)

Comment 4

19 years ago
This should be a non-quirk mode behavior, activated by the HTML 4.0 Strict
Doctype. 4.x shows the line break preceeding the ETAGO.

(The attachment made by klein_sh@inter.net.il does not include a HTML 4.0
Strict Doctype, so it is rendered correctly (with 4.x's quirks). The second
part of that attachment only displays correctly because there is no discernable
difference between bold and not bold whitespace.)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Marking a duplicate of bug 2750.

*** This bug has been marked as a duplicate of 2750 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Good catch -- verifying.

Comment 7

18 years ago
*** Bug 63839 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.