Closed Bug 1049088 Opened 8 years ago Closed 7 years ago

[B2G][Marketplace] When adding a video to the playlist, the user will get a error message on the youtube app

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: psiphantong, Unassigned)

References

()

Details

(Whiteboard: [2.0-exploratory])

Attachments

(1 file)

Attached file yy.txt
When adding a video to the playlist, the user will get a error message on the YouTube app 

Prerequisites:
Download & install Youtube from Marketplace 

Repro Steps:
1) Update a Flame device to BuildID: 20140805000238
2) Go to the YouTube app
3) Tap a video 
4) Tap the plus sign 


Actual:
User gets a error message 

Expected:
User adds video to the playlist without the error message 

Environmental Variables:
Device: Flame 2.0
Build ID: 20140805000238
Gaia: 597975839c04e0198eb98c2c77474f057b5531e7
Gecko: ddeead927143
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Note: when user tap the 'ok' button on the error mmessage, there will be loading screen that goes nowhere unless the user taps cancel 


Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=FCqjPO8wlNY
This issue also reproduces on the Flame 2.1 (319mb), Flame 2.0(512mb), Buri 2.0, Flame 1.4(319mb),Buri 1.4, Buri 1.3. User gets a error message page. 


Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140805040204
Gaia: 19bf9795263e2ccc15d824a52ebf23c2670fa9b9
Gecko: 7f81be7db528
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0(512mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140805000238
Gaia: 597975839c04e0198eb98c2c77474f057b5531e7
Gecko: ddeead927143
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140805063011
Gaia: 4959d1eb92fa82198409c90f471aad6d68c463b3
Gecko: c18fb97addb8
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4(273MB)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140804183020
Gaia: 9377274b17200a60cebcd2427d489a7756c4cc72
Gecko: 24bc2ae19c59
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140804183020
Gaia: 9377274b17200a60cebcd2427d489a7756c4cc72
Gecko: 24bc2ae19c59
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.3

Environmental Variables:
Device: Buri 1.3
Build ID: 20140725024005
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: 9727017eabb9
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

__________________________________________________________________________________________________________

The issue does not reproduce on the Buri 2.1 because the google sign page does not function 

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140805073149
Gaia: 19bf9795263e2ccc15d824a52ebf23c2670fa9b9
Gecko: 2aaedcdf69f6
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
correction, the 2.1 v122 base is actually v123 base
Please correct the memory of each device.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(psiphantong)
Please ignore the Flame 2.1 (273mb), Flame 1.4 (273mb) comment. They're both (319mb)
Flags: needinfo?(psiphantong) → needinfo?(ktucker)
Somehow this is not a regression but nominating 2.0? since the user is presented with an error message anytime they try to add a video to a playlist. Also, an endless loading screen occurs. The user can get out of the loading screen by tapping "cancel" though.
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triag+]
Flags: needinfo?(ktucker)
Pete, please look into the sign in not working on Buri 2.1 and log a bug if necessary.
QA Whiteboard: [QAnalyst-Triag+] → [QAnalyst-Triage-]
Flags: needinfo?(psiphantong)
Wrote up the Buri 2.1 bug, https://bugzilla.mozilla.org/show_bug.cgi?id=1049250
Flags: needinfo?(psiphantong) → needinfo?(ktucker)
Clearing the nomination here since this is a TE issue.
blocking-b2g: 2.0? → ---
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I was unable to reproduce this issue while testing for bug on reference device. I am able to add videos to playlists within the YouTube app without issue. 

Closing this bug - Works for Me.
Blocks: b2g-youtube
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.