Show a default view when there are no search history items

RESOLVED DUPLICATE of bug 1049206

Status

P1
normal
RESOLVED DUPLICATE of bug 1049206
4 years ago
10 months ago

People

(Reporter: antlam, Assigned: eedens)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Since there is nothing left to do after the user clears their history, we should take them out of the settings page (where there is currently only one action).

Updated

4 years ago
Blocks: 1017135

Updated

4 years ago
Assignee: nobody → eric.edens

Comment 1

4 years ago
P1 to refine this behavior a bit.

Talking with antlam, we'd like to explore also focusing the search bar after exiting settings, since there's nothing else for the user to do if there are no search history items.

We should also clear the search bar if there's any text in it, since that would contain an old query that the user is trying to get rid of.
Priority: -- → P1
(Reporter)

Comment 2

4 years ago
Created attachment 8469726 [details]
XXHDPI - Mobile - Cleared history.png

Attaching some visual treatment for the empty state of which the user will be in after history is cleared.
Where are we switching the default search egine? I assumed that would happen in Settings too, which means the "Clear search history" would not be the only think in Settings. Therefore, this bug is WONTFIX.
(Reporter)

Comment 4

4 years ago
(In reply to Mark Finkle (:mfinkle) from comment #3)
> Where are we switching the default search egine? I assumed that would happen
> in Settings too, which means the "Clear search history" would not be the
> only think in Settings. Therefore, this bug is WONTFIX.

I guess that makes sense. But this screen (minus the keyboard being up) will still need to exist if the user had say 1 search term/history item and manually removed it. Perhaps that should be in another bug.
(Assignee)

Comment 5

4 years ago
(In reply to Anthony Lam (:antlam) from comment #4)

> I guess that makes sense. But this screen (minus the keyboard being up) will
> still need to exist if the user had say 1 search term/history item and
> manually removed it. Perhaps that should be in another bug.

Why does it need to exist? We give immediate confirmation after clearing the history through a Toast.

Comment 6

4 years ago
We may just more generally need something to show when there are no history items, similarly to how we have empty views in about:home. Otherwise, if there's a totally blank screen, it looks like the app may be busted.

I agree with mfinkle that this bug becomes a WONTFIX once we have more items in the settings screen, so I'm just going to morph this to be about the empty state.
Summary: Exit "settings" after user clears their history → Show a default view when there are no search history items
(Reporter)

Comment 7

4 years ago
Yeah - I think that's a good call. Good morph! (Power Rangers reference)

I think we definitely still need this. My hope for this is really two fold:

1) (Like Margaret said) provide a better empty state that informs the user
2) Use this opportunity to show some character/whimsy and to be with the user in that moment of satisfaction

Comment 8

4 years ago
I'm duping this to bug 1049206.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049206

Updated

10 months ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.