Closed Bug 1049282 Opened 6 years ago Closed 6 years ago

Unable to use gesture typing in search activity

Categories

(Firefox for Android Graveyard :: Search Activity, defect, P1)

Other
Android
defect

Tracking

(fennec+)

RESOLVED FIXED
Firefox 34
Tracking Status
fennec + ---

People

(Reporter: blassey, Assigned: eedens)

References

Details

Attachments

(1 file)

No description provided.
tracking-fennec: --- → ?
Blocks: search
This may be related to how we hide the keyboard's suggestions:

https://lxr.mozilla.org/mozilla-central/source/mobile/android/search/res/layout/clearable_edit_text.xml#13

Whether we want to continue hiding the suggestions is another question :)  --  the original thinking was to conserve some vertical pixels, since we're already getting suggestions over the wire.
Priority: -- → P1
(In reply to Eric Edens [:eedens] from comment #1)
> This may be related to how we hide the keyboard's suggestions:
> 
> https://lxr.mozilla.org/mozilla-central/source/mobile/android/search/res/
> layout/clearable_edit_text.xml#13
> 
> Whether we want to continue hiding the suggestions is another question :) 
> --  the original thinking was to conserve some vertical pixels, since we're
> already getting suggestions over the wire.

I think we've made the wrong trade off here. This breaks the users regular method of text input, slowing them down greatly at the cost of one row of suggestions.
tracking-fennec: ? → +
> I think we've made the wrong trade off here. This breaks the users regular
> method of text input, slowing them down greatly at the cost of one row of
> suggestions.

To clarify, which method is 'regular method of text input' referring to? Keyboard suggestions or gesture typing?

If gesture typing, then I agree: we should fix that for sure.

If keyboard suggestions, I think it's normal to hide keyboard's suggestions for search bars. I just tried three apps with search bars (Fennec, Chrome, and the Play Store), and none show the keyboard's suggestions.
Flags: needinfo?(blassey.bugs)
(In reply to Eric Edens [:eedens] from comment #3)
> > I think we've made the wrong trade off here. This breaks the users regular
> > method of text input, slowing them down greatly at the cost of one row of
> > suggestions.
> 
> To clarify, which method is 'regular method of text input' referring to?
> Keyboard suggestions or gesture typing?
> 
> If gesture typing, then I agree: we should fix that for sure.
> 
> If keyboard suggestions, I think it's normal to hide keyboard's suggestions
> for search bars. I just tried three apps with search bars (Fennec, Chrome,
> and the Play Store), and none show the keyboard's suggestions.

The gesture typing specifically, but I also disagree with removing suggestions as well. You can see my comments in the Fenenc bug that disabled suggestions as to why.
Flags: needinfo?(blassey.bugs)
Duplicate of this bug: 1052285
Confirmed gesture typing works with Google's keyboard and Swiftkey. (Swiftkey shows a suggestion bar, Google does not).

The `textVisiblePassword` was a hack -- one of the older test phones showed suggestions regardless of the `textNoSuggestions` flag. Clearly, though, it had the unintended consequence of killing suggestions.

On the question of whether or not to suppress suggestions -- if people think that's important, we can open another bug. :) 

PR: https://github.com/mozilla/fennec-search/pull/56
Assignee: nobody → eric.edens
Status: NEW → ASSIGNED
Attachment #8471674 - Flags: review?(margaret.leibovic)
Comment on attachment 8471674 [details] [diff] [review]
bug-1049282-fix.patch

Review of attachment 8471674 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I think we should get some UX feedback about suggestions.
Attachment #8471674 - Flags: review?(margaret.leibovic) → review+
(In reply to :Margaret Leibovic from comment #7)
> Comment on attachment 8471674 [details] [diff] [review]
> bug-1049282-fix.patch
> 
> Review of attachment 8471674 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good. I think we should get some UX feedback about suggestions.

After speaking with Eric, I realized that this matches what we currently do for Fennec's location bar, so I'm fine with just maintaining consistency for now.
https://hg.mozilla.org/mozilla-central/rev/9631886da333
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Duplicate of this bug: 1053772
Duplicate of this bug: 1050614
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.