Closed Bug 104973 Opened 20 years ago Closed 3 months ago

Port |Bug 431217 - Send button should be disabled until we have a recipient| to SeaMonkey

Categories

(SeaMonkey :: MailNews: Composition, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
seamonkey 2.88
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: stephend, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.9)

Attachments

(1 file)

Build:  Current trunk CVS, Windows 2000 (but applies to all OSs)

Summary:  Send button should be disabled until we have a recipient.

Steps to Reproduce:

1.  Launch mozilla.exe -compose or just do a CTRL+M to bring up the compose window.

Expected Results:

Until you have a recipient, the Send button should be disabled. 

Actual Results:

The Send button is enabled, and of course gives an error, "Sending of message
failed: No recipients were specified...", etc. etc.

Logic:  In commercial builds were the Spell button exists on this toolbar, we
disable that button until we have text to check in the body.  Strange that
Outlook Express 6 and Netscape Messenger 4.x both have this button also enabled,
and both give the same expected error.

It's seemingly such an obvious bug.  Is there any reason it should be enabled
until we have a recipient?  I can't think of any.
-->varada
Assignee: ducarroz → varada
Keywords: nsbeta1
Keywords: nsbeta1nsbeta1-
still exists->2001-12-14-06
changing QA contact from Sheela to Gregg
QA Contact: sheelar → meehansqa
Blocks: 154188
taking all of varada's bugs.
Assignee: varada → sspitzer
Product: MailNews → Core
Assignee: sspitzer → nobody
Severity: normal → enhancement
QA Contact: meehansqa
QA Contact: composition
Blocks: 431217
Product: Core → MailNews Core
I am not sure there is any composition code in mailnews where this can be done. This should be moved to Seamonkey.
Thunderbird bug is bug 431217.
No longer blocks: 431217
Component: Composition → MailNews: Composition
Depends on: 431217
Product: MailNews Core → SeaMonkey
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Summary: Send button should be disabled until we have a recipient. → Port |Bug 431217 - Send button should be disabled until we have a recipient| to SeaMonkey

Port relevant changes from:

  • Bug 431217 - Send button should be disabled until we have a recipient
  • Bug 863231 - Enable Send button properly when filling recipients via Contacts sidebar
  • Bug 933101 - Properly enable Send button if recipients are drag'n'dropped into the address widget or filled in by switching identities
  • Bug 1290733 - Speed up UpdateSendLock() in compose window by only looking for one valid recipient
  • Bug 1296535 - Enable Send button when recipient is a mailinglist
  • Bug 1362130 - enable Send button when mailinglist name gets quoted

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: send button always active
Testing completed (on m-c, etc.): 2.53.9
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none

Attachment #9223129 - Flags: review?(frgrahl)
Attachment #9223129 - Flags: approval-comm-release?
Attachment #9223129 - Flags: approval-comm-esr60?

Comment on attachment 9223129 [details] [diff] [review]
104973-compose-sendlock-2539.patch

LGTM

Bug 1701313 added a new simple newsgroup name validation in case we want this later. Send was enabled correctly during my tests so I hope mentioned bugs in this tB bug are because of the pillified address lines only.

Attachment #9223129 - Flags: review?(frgrahl)
Attachment #9223129 - Flags: review+
Attachment #9223129 - Flags: approval-comm-release?
Attachment #9223129 - Flags: approval-comm-release+
Attachment #9223129 - Flags: approval-comm-esr60?
Attachment #9223129 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/13f3e211a627
Port |Bug 431217 - Send button should be disabled until we have a recipient| to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.9
Target Milestone: --- → seamonkey 2.88
Regressions: 1719922
You need to log in before you can comment on or make changes to this bug.