Closed Bug 1050121 Opened 6 years ago Closed 6 years ago

package-manifest:50: Missing file(s): bin/icudtd52.dll

Categories

(SeaMonkey :: Build Config, defect)

SeaMonkey 2.29 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1022702

People

(Reporter: ewong, Assigned: ewong)

Details

Attachments

(3 obsolete files)

This is from a comm-beta Win build:

e:/builds/slave/c-beta-w32-dbg/build/objdir/mozilla/_virtualenv/Scripts/python.exe e:/builds/slave/c-beta-w32-dbg/build/mozilla/toolkit/mozapps/installer/packager.py -DOSTYPE=\"WINNT5.2\" -DOSARCH=WINNT -DNO_NSPR_10_SUPPORT -DAB_CD=en-US -DMOZ_APP_NAME=seamonkey -DPREF_DIR=defaults/pref -DJAREXT= -DENABLE_TESTS=1 -DMOZ_ANGLE_RENDERER=1 -DMOZ_D3DCOMPILER_XP_DLL=D3DCompiler_43.dll -DMOZ_DEBUG=1 -D_MSC_VER=1600 -DMOZ_URL_CLASSIFIER=1 -DMOZ_UPDATER=1 -DNECKO_WIFI=1 -DMOZ_MSVC_REDIST=1600 -DMOZ_SHARED_MOZGLUE=1 -DMOZ_CHILD_PROCESS_NAME=plugin-container.exe -DDLL_PREFIX= -DDLL_SUFFIX=.dll -DBIN_SUFFIX=.exe -DMOZ_FOLD_LIBS=1 -DBINPATH=bin -DMOZ_ICU_VERSION=52 -DMOZ_SHARED_ICU \
	--format omni \
	--removals e:/builds/slave/c-beta-w32-dbg/build/suite/installer/removed-files.in \
	 \
	 \
	 \
	 \
	--optimizejars \
	 \
	package-manifest ../../mozilla/dist ../../mozilla/dist/seamonkey \
	--non-resource defaults/messenger/mailViews.dat defaults/profile/localstore.rdf defaults/profile/panels.rdf 
Error: e:\builds\slave\c-beta-w32-dbg\build\objdir\suite\installer\package-manifest:50: Missing file(s): bin/icudtd52.dll
Error: e:\builds\slave\c-beta-w32-dbg\build\objdir\suite\installer\package-manifest:51: Missing file(s): bin/icuind52.dll
Error: e:\builds\slave\c-beta-w32-dbg\build\objdir\suite\installer\package-manifest:52: Missing file(s): bin/icuucd52.dll
Traceback (most recent call last):
  File "e:/builds/slave/c-beta-w32-dbg/build/mozilla/toolkit/mozapps/installer/packager.py", line 402, in <module>
    main()
  File "e:/builds/slave/c-beta-w32-dbg/build/mozilla/toolkit/mozapps/installer/packager.py", line 354, in main
    copier.add(mozpack.path.join(binpath, 'removed-files'), removals)
  File "d:\mozilla-build\python27\Lib\contextlib.py", line 24, in __exit__
    self.gen.next()
  File "e:\builds\slave\c-beta-w32-dbg\build\mozilla\python\mozbuild\mozpack\errors.py", line 129, in accumulate
    raise AccumulatedErrors()
mozpack.errors.AccumulatedErrors
Attached patch bustage fix patch (v1) (obsolete) — Splinter Review
[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: windows debug beta build busted
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8469094 - Flags: review?(bugzilla)
Attachment #8469094 - Flags: approval-comm-beta?
Comment on attachment 8469094 [details] [diff] [review]
bustage fix patch (v1)

This is for a post-push review.
Attached patch bustage fix patch (v2) (obsolete) — Splinter Review
Attachment #8469094 - Attachment is obsolete: true
Attachment #8469094 - Flags: review?(bugzilla)
Attachment #8469094 - Flags: approval-comm-beta?
Attachment #8469099 - Flags: review?(neil)
Comment on attachment 8469099 [details] [diff] [review]
bustage fix patch (v2)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: windows debug build busted
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8469099 - Flags: approval-comm-beta?
Attached patch patch (V3) (obsolete) — Splinter Review
Attachment #8469099 - Attachment is obsolete: true
Attachment #8469099 - Flags: review?(neil)
Attachment #8469099 - Flags: approval-comm-beta?
Attachment #8469102 - Flags: review?(neil)
Comment on attachment 8469102 [details] [diff] [review]
patch (V3)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8469102 - Flags: approval-comm-beta?
Comment on attachment 8469102 [details] [diff] [review]
patch (V3)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: windows debug build bustage.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8469102 - Flags: approval-comm-release?
Attachment #8469102 - Attachment is obsolete: true
Attachment #8469102 - Flags: review?(neil)
Attachment #8469102 - Flags: approval-comm-release?
Attachment #8469102 - Flags: approval-comm-beta?
Closing this bug.  This is a fallout of not uplifting the patch for
bug 1022702.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022702
You need to log in before you can comment on or make changes to this bug.