Search activity edit field has border on Android 4.1

VERIFIED FIXED in Firefox 35

Status

P1
normal
VERIFIED FIXED
4 years ago
7 months ago

People

(Reporter: aaronmt, Assigned: Margaret)

Tracking

34 Branch
Firefox 35
ARM
Android
Dependency tree / graph

Details

(Whiteboard: shovel-ready)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8469500 [details]
screenshot.png

See screenshot

--
Nightly (08/07)
Samsung Galaxy SII (Android 4.1.2)
(Assignee)

Comment 1

4 years ago
The real bug there is that there's a border at all. There should only be a border on the bottom.

Aaron, do you know the screen density of the device you were testing? Is that border always there?
Summary: Search activity magnifying glass/edit field close button overlap with border on Android 4.1 → Search activity edit field has border on Android 4.1
(Assignee)

Updated

4 years ago
Priority: -- → P1
(Reporter)

Comment 2

4 years ago
(In reply to :Margaret Leibovic from comment #1)
> The real bug there is that there's a border at all. There should only be a
> border on the bottom.
> 
> Aaron, do you know the screen density of the device you were testing? Is
> that border always there?

Galaxy SII is high-density (hdpi)/normal screen size, yes that border is always there
(Assignee)

Updated

4 years ago
Assignee: nobody → margaret.leibovic
(Assignee)

Comment 3

4 years ago
I noticed that there is also a problem with the border on my Nexus S (2.3.6).

Fixing this will involve tweaking the edit_text_background drawable:
https://github.com/mozilla/fennec-search/blob/master/app/src/main/res/drawable/edit_text_background.xml
Assignee: margaret.leibovic → nobody
Whiteboard: shovel-ready
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1059463
(Assignee)

Comment 5

4 years ago
This will probably be fixed by my patch in bug 1049600.
(Assignee)

Comment 6

4 years ago
This should be fixed by the patch in bug 1049600. The issue was resolved for me where I was experiencing it (Nexus S).

Aaron, can you try this again when bug 1049600 hits Nightly?
Depends on: 1049600
Flags: needinfo?(aaron.train)
(Assignee)

Updated

4 years ago
Assignee: nobody → margaret.leibovic
(Reporter)

Comment 7

4 years ago
Created attachment 8493759 [details]
screenshot.png

This is still seen on trunk Nightly (09/23).

What it looks like now
Flags: needinfo?(aaron.train)
(Assignee)

Comment 8

4 years ago
Created attachment 8494867 [details] [diff] [review]
ncrease top/right/left alues of edit_text_focus layer-list drawable to fix pixel issue on 4.1

Not gonna lie, I don't totally understand why this was happening (and only on some devices). It seems like it's some screen resolution problem, but expanding the edges of the rectangle we use to hide the top/right/left border by 1dp appears to fix the problem, without causing regressions on other devices.
Attachment #8494867 - Flags: review?(liuche)
https://hg.mozilla.org/mozilla-central/rev/dab8d3c1e8c9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35

Comment 11

4 years ago
Verified as fixed in build 35.0a1 (2014-10-02);
Device Samsung Galaxy S2 (Android 4.1.2);
Status: RESOLVED → VERIFIED
status-firefox35: --- → verified

Updated

7 months ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.