'Null' shown in voice mail notification

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: echang, Assigned: smaug)

Tracking

({regression})

unspecified
2.1 S2 (15aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8469845 [details]
v2.0-flame-voicemail-notification.png

### STR
1. send a voice mail to device
2. check the notification

### Actual
'null' shown
v2.1-buri-voicemail-notification.png
v2.1-flame-voicemail-notification.png

### Expected
'One new voicemail'
v2.0-flame-voicemail-notification.png

### Version
v2.0-Flame
Gaia      8cb1a949f2e9650bb2c5598e78a6f24a58bbaf97
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/4bd4b0ae7bbe
BuildID   20140721000201
Version   32.0a2
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230


v2.1-Flame
Gaia      54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko     https://hg.mozilla.org/mozilla-central/rev/bd44d84142e8
BuildID   20140807160201
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230

v2.1-Buri
Gaia      15c84c943e41ad834640a45e1e1c2ac804168af7
Gecko     https://hg.mozilla.org/mozilla-central/rev/30907d52c4c2
BuildID   20140723160203
Version   34.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
(Reporter)

Comment 1

4 years ago
Created attachment 8469846 [details]
v2.1-flame-voicemail-notification.png
(Reporter)

Comment 2

4 years ago
Created attachment 8469847 [details]
v2.1-buri-voicemail-notification.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=Gaia::System]
(Reporter)

Comment 3

4 years ago
hi, arthur, could you help to check this, thanks.
Flags: needinfo?(arthur.chen)
Alexandre might know better than me regarding voicemail notifications.
Flags: needinfo?(arthur.chen) → needinfo?(lissyx+mozillians)
I don't have any issue on my Nexus S running master.
Flags: needinfo?(lissyx+mozillians)
Assignee: nobody → lissyx+mozillians
Keywords: regression
Whiteboard: [systemsfe]
I got to reproduce if I leave a Voicemail on my Free Mobile SIM card and reboot. When it happens, I have a "null" string, and not a |null| value.
I see that bug 906404 did some changes to the Voicemail API in master a couple of weeks ago.
[Blocking Requested - why for this release]: regression.
blocking-b2g: --- → 2.1?
After a local backout of bug 906404 (1e6a327d21a754096a12d84beede62501523d4e9), I do not reproduce the issue anymore.
Flags: needinfo?(vyang)
Flags: needinfo?(roshanvid)
Flags: needinfo?(bugs)
Depends on: 906404
(Assignee)

Comment 10

4 years ago
Does anyone happen to know what thing is showing the null? I mean what code.
Flags: needinfo?(bugs)
(Assignee)

Comment 12

4 years ago
Aha, returnNumber and returnMessage should both be probably nullable.
Otherwise the internal null will be converted to "null" string.
Flags: needinfo?(bugs)
(Assignee)

Comment 13

4 years ago
Created attachment 8470866 [details] [diff] [review]
possible patch

Could anyone test this?
(I don't know how to even send voice mail)
(Assignee)

Updated

4 years ago
Flags: needinfo?(lissyx+mozillians)
Attachment #8470866 - Flags: feedback+
That does fix the issue, as far as I can tell.
Flags: needinfo?(vyang)
Flags: needinfo?(roshanvid)
Flags: needinfo?(lissyx+mozillians)
Assignee: lissyx+mozillians → nobody
Component: Gaia::System → RIL
(Assignee)

Updated

4 years ago
Attachment #8470866 - Flags: review?(ehsan)

Updated

4 years ago
Blocks: 906404
No longer depends on: 906404

Updated

4 years ago
Attachment #8470866 - Flags: review?(ehsan) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Assignee: nobody → bugs
https://hg.mozilla.org/integration/b2g-inbound/rev/56ff14a9e0f6
status-b2g-v2.1: affected → fixed
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/56ff14a9e0f6
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S2 (15aug)

Updated

4 years ago
Duplicate of this bug: 1045208
Already in 2.1
blocking-b2g: 2.1? → ---
(Reporter)

Comment 19

4 years ago
Gaia-Rev        b542080231bb9cdbdb282ab926965ad3f91f7460
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/d614ae398c03
Build-ID        20140923155123
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.