Closed Bug 1050748 Opened 9 years ago Closed 8 years ago

[l10n] Cancel button is not localized when displaying matches from contacts in Dialer

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED DUPLICATE of bug 1057619
2.1 S3 (29aug)
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: flod, Assigned: jorgep)

References

Details

(Keywords: l12y)

Attachments

(2 files)

Open dialer, start typing a phone number, touch the number that shows the matches in your contacts.

The "Cancel" button is displayed in English, while the rest of the screen is correctly localized.

I'm seeing this on Flame, but it's not recent (Keon running build from 20140708 has the same issue).

Gaia      c45627132ae7f00026e361a14d5d084a1236af24
Gecko     https://hg.mozilla.org/mozilla-central/rev/18f408a5984e
BuildID   20140808040304
Version   34.0a1
Issue was reported also in bug 1022445, but it was never fixed there (assumption or being related to bug 1019076 was clearly wrong).
Assignee: nobody → jpruden92
Status: NEW → ASSIGNED
Attached file 23200.html
Attachment #8477371 - Flags: review?(anthony)
Silly question: do we actually need the string in dialer.properties? We have one in contacts.properties, and last time I check all /communications sub-apps are merged in a single json object on the phone.
[Blocking Requested - why for this release]: This seems to affect 2.0.
blocking-b2g: --- → 2.0?
Comment on attachment 8477371 [details]
23200.html

Doug: You've done some work on those L10n issues before. I'm not sure this is the proper way to fix this.

Flod: I agree we should re-use the Contacts strings. Because 1) we're already including them, 2) New strings won't be accepted for a 2.0 uplift.
Attachment #8477371 - Flags: review?(anthony) → review?(drs+bugzilla)
Comment on attachment 8477371 [details]
23200.html

Using navigator.mozL10n.translateFragment() for lazy-loaded elements is the correct approach, but it's in the wrong spot, and as Anthony and Francesco have indicated, the new "Cancel" string is unnecessary.

Also, this needs a unit test. We should test that when _initOverlay() is called, the suggestion overlay has navigator.mozL10n.translateFragment() called on it.

I left more detailed comments in the PR.
Attachment #8477371 - Flags: review?(drs+bugzilla) → review-
I believe we want two different patches - translateFragment for 2.0 and without it for 2.1 and up
Zibi and I are looking into this. It looks worse than we realized before. There seems to be some kind of error within translateFragment and translateElement for loading some fragments. Here's a test case I wrote up for this bug:
https://pastebin.mozilla.org/6101009

It looks so far like this is a problem with l10n rather than the dialer. But we still have more digging to do.
Depends on: 1057619
This will be fixed for free when bug 1057619 is.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → 2.1 S3 (29aug)
(In reply to Doug Sherk (:drs) from comment #10)
> This will be fixed for free when bug 1057619 is.
> 
> *** This bug has been marked as a duplicate of bug 1057619 ***

Clearing nom here and blocking the DUP instead.
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.