Thunderbird replies to a list based on a nickname found among recipients of original message

RESOLVED DUPLICATE of bug 1008718

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1008718
4 years ago
4 years ago

People

(Reporter: tvamana, Unassigned)

Tracking

({regression})

31 Branch
x86
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I get an email sent to several (consider 5) recipients, of whom I see in the messages header their real email adress as well as their nickname in the adress book of the sender. One of those nick names happen to be exactly same like the name of one of the lists (groups) in my adress book (upper / lower case not important). I want to reply to all those 5 people so I click on "Reply to all". A window opens for composing the reply message. In the header I still see just the 5 people that I am intending to reply - so far correct. I click Send.


Actual results:

The message is sent not (only) to intended 5 people, but to a whole bunch of other people who have nothing to do with the original message!
The reason I found is the nickname in the original message vs. the name of my list / group. Thunderbird seems to look at this nickname and decides that the reply should be sent to the list / group of mine instead of the original mail adress with the same nick name!


Expected results:

It should of course only work with mail adresses, not nick names.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1008718
You need to log in before you can comment on or make changes to this bug.