Closed Bug 1050780 Opened 5 years ago Closed 5 years ago

Browser menu missing dividers in Android L Preview

Categories

(Firefox for Android :: General, defect)

35 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35
Tracking Status
firefox33 --- fixed
firefox34 --- fixed
firefox35 --- fixed
fennec 33+ ---

People

(Reporter: aaronmt, Assigned: lucasr)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image screenshot.png
On Android L Preview (LPV81C), the in-browser menu seems to be missing a bunch of dividers for each menu item.

See screenshot.

--
Nexus 7 (L Preview LPV81C)
See Also: → 963249
Similar to bug 963249, the dividers are missing only when the menu is opened on about:home again
Attached image screenshot-content.png
Actually I retract that. Here's an example in content with the 'Page' menu missing dividers.
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: --- → ?
For the record, it seems we've had similar issues before. See bug 963249.
Let's track this to get it in ASAP, and we can look to uplift if there's a low-risk fix.
tracking-fennec: ? → 33+
Comment on attachment 8481442 [details] [diff] [review]
Avoid disabled items in GeckoMenu's adapter (r=margaret)

Review of attachment 8481442 [details] [diff] [review]:
-----------------------------------------------------------------

I initially thought this was an Android bug but it seems this is the intended behaviour in ListView. Dividers are not drawn around items disabled in the adapter. See:
https://github.com/android/platform_frameworks_base/blob/master/core/java/android/widget/ListView.java#L3274

I had to change the background selector to only show pressed state on enabled menu items as the ListView's OnItemClickListener will still set pressed state on the disabled menu item.
Attachment #8481442 - Flags: review?(margaret.leibovic)
Attachment #8481442 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/mozilla-central/rev/8fc296b9a1df
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Version: Firefox 34 → Firefox 35
Comment on attachment 8481442 [details] [diff] [review]
Avoid disabled items in GeckoMenu's adapter (r=margaret)

Approval Request Comment
[Feature/regressing bug #]: the Android L release
[User impact if declined]: menu looks visually broken when certain items are disabled.
[Describe test coverage new/current, TBPL]: Local testing on Kitkat/L devices only. Let's bake this in Nightly for a few days and then uplift.
[Risks and why]: Low, simply avoid disabling items in the menu's adapter so that dividers are always drawn before/after them.
[String/UUID change made/needed]: n/a
Attachment #8481442 - Flags: approval-mozilla-beta?
Attachment #8481442 - Flags: approval-mozilla-aurora?
Attachment #8481442 - Flags: approval-mozilla-beta?
Attachment #8481442 - Flags: approval-mozilla-beta+
Attachment #8481442 - Flags: approval-mozilla-aurora?
Attachment #8481442 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.