Closed Bug 963249 Opened 6 years ago Closed 6 years ago

Regression: Menu difference on tablets between about:home and content

Categories

(Firefox for Android :: Theme and Visual Design, defect)

29 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- affected
firefox30 --- fixed
fennec 29+ ---

People

(Reporter: aaronmt, Assigned: bnicholson)

References

Details

(Keywords: regression, reproducible, Whiteboard: [tablet])

Attachments

(3 files)

Attached image about:home screenshot
See screenshot.

For whatever reason when Find in Page is disabled, we have a couple dividers removed.

--
Nightly (01/23)
Samsung Galaxy Tab 3 10" (x86)
Attached image content screenshot
Whiteboard: [tablet]
* Find in Page should be disabled for about:home
* I wonder if the dividers are not drawn if the menu id disabled? Looks like the divider is drawn for Share though.
Assignee: nobody → bnicholson
tracking-fennec: ? → 29+
Can't reproduce this on the Android emulator -- have you seen this on non-x86 tablets as well?
Flags: needinfo?(aaron.train)
Yes. On my Xperia Tablet Z: bug 970365. 

Forgot I filed this. Duping my new one
Flags: needinfo?(aaron.train)
Duplicate of this bug: 970365
Sony Xperia Z Tablet screenshot: https://bugzilla.mozilla.org/attachment.cgi?id=8373393
Having a ListView item disabled hides the dividers for that item, and this appears to be the "intended behavior" [1]. The workaround, according to several sources ([2], [3], etc.) is to override areAllItemsEnabled in the adapter to always return true. I can verify that this fixes the divider issue, and the individual items are still disabled as expected.

[1] https://groups.google.com/d/msg/android-developers/uoiJo0djRZ8/wb-iOy5bmawJ
[2] http://stackoverflow.com/a/9197037/1524401
[3] http://java.dzone.com/articles/android-listview-%E2%80%93-fixing
Attachment #8379549 - Flags: review?(wjohnston)
Status: NEW → ASSIGNED
Hardware: x86 → All
Comment on attachment 8379549 [details] [diff] [review]
Override MenuItemsAdapter#areAllItemsEnabled to always be true

Review of attachment 8379549 [details] [diff] [review]:
-----------------------------------------------------------------

:(
Attachment #8379549 - Flags: review?(wjohnston) → review+
Yeah, I don't like this fix either. When areAllItemsEnabled() returns true, individual items can still still be disabled, so what does areAllItemsEnabled() actually *do*?

https://hg.mozilla.org/integration/fx-team/rev/8f547ee05df3
https://hg.mozilla.org/mozilla-central/rev/8f547ee05df3
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
See Also: → 1050780
You need to log in before you can comment on or make changes to this bug.