[B2G][Contacts] Export contacts buttons are overlaying Settings menu page

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jdegeus, Assigned: jmcf)

Tracking

({regression})

unspecified
2.1 S2 (15aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [2.0-exploratory], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8470118 [details]
Logcat_export.txt

Description:
When users select to Export Contacts, upon selecting a method of exporting, users can select the Setting gear icon on the top right corner of the page. Users will then be brought to the Settings page which will retain the Export Contacts buttons such as "Select All", "Deselect All", "Export" and "Cancel". These buttons remain fully functional.

Repro Steps:
1) Update a Flame to 20140808000201
2) Select Contacts> Settings> Export Contacts
3) Select Bluetooth or Memory Card> Immediately tap Settings on the top right corner
4) Observe the Export contact buttson remain on screen when user transitions into the Settings menu

Actual:
Export contacts buttons remain on screen and overlay the Settings menu page

Expected:
Users are prevented from entering Settings menu after electing to export contacts

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140808000201
Gaia: 8d4599d18fbfc41f88ea494ab9cce0bb99cffac3
Gecko: aad73d079368
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 4/5
See attached: Video and logcat attached
http://youtu.be/Ut4ztMddt2A - Logcat_export
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.1 (319mb), Flame 2.0 (512mb), Buri 2.1, and Buri 2.0

Actual: Users will see the Export buttons displaying within the Contacts/Settings

Flame 2.1 (319mb)

Environmental Variables:
Device: Flame 2.1 Master
BuildID: 20140808040304
Gaia: c45627132ae7f00026e361a14d5d084a1236af24
Gecko: 18f408a5984e
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.0 (512mb)

Enviromental Variables:
Device: Flame 2.0
BuildID: 20140808000201
Gaia: 8d4599d18fbfc41f88ea494ab9cce0bb99cffac3
Gecko: aad73d079368
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140807193101
Gaia: c45627132ae7f00026e361a14d5d084a1236af24
Gecko: 18f408a5984e
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140808003002
Gaia: 8d4599d18fbfc41f88ea494ab9cce0bb99cffac3
Gecko: aad73d079368
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

--------------------------------------------------------------------

This issue DOES NOT occur on Flame 1.4 (319mb), Buri 1.4

Actual: Users are not able to select Settings after they choose to Export Contacts

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140806183051
Gaia: e9dce1f60f729e228810f751417681b5ff937b6b
Gecko: 89a8a24a8b1b
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4

Enviromental Variables:
Device: Buri 1.4
BuildID: 20140808063002
Gaia: 2b2849a61cd38e909ed1c3e4586d104bc96f7001
Gecko: 931bf8651711
Version: 30.0 (1.4)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This is occurring all through contacts. This will confuse the end user because the wrong options overlay will be shown. This is also a regression. Nominating 2.0?
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(Reporter)

Comment 3

4 years ago
This issue can also occur when users tap "Delete Contacts" then immediately tap a contact.
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140429103008
Gaia: 1892ba3a857f7e9cd1d2a0cf1c87481f3dcaca2c
Gecko: 34a7215c5d85
Platform Version: 32.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First broken
BuildID: 20140429163003
Gaia: db3bcec51a361daddb7d3d4ba4d8a2a664b7b6aa
Gecko: 90267d87c375
Platform Version: 32.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Working Gaia / Broken Gecko = No repro
Gaia: 1892ba3a857f7e9cd1d2a0cf1c87481f3dcaca2c
Gecko: 90267d87c375
Broken Gaia / Working Gecko = Repro
Gaia: db3bcec51a361daddb7d3d4ba4d8a2a664b7b6aa
Gecko: 34a7215c5d85
Gaia push log: https://github.com/mozilla-b2g/gaia/compare/1892ba3a857f7e9cd1d2a0cf1c87481f3dcaca2c...db3bcec51a361daddb7d3d4ba4d8a2a664b7b6aa


B2G-inbound
Last working
BuildID: 20140429053002
Gaia: 1892ba3a857f7e9cd1d2a0cf1c87481f3dcaca2c
Gecko: 0d45d99bba09
Platform Version: 32.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First broken
BuildID: 20140429083002
Gaia: feef47764b9ae49fa5cc28a07186db7905481297
Gecko: 81dc74c9a5a2
Platform Version: 32.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Working Gaia / Broken Gecko = No repro
Gaia: 1892ba3a857f7e9cd1d2a0cf1c87481f3dcaca2c
Gecko: 81dc74c9a5a2
Broken Gaia / Working Gecko = Repro
Gaia: feef47764b9ae49fa5cc28a07186db7905481297
Gecko: 0d45d99bba09
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/1892ba3a857f7e9cd1d2a0cf1c87481f3dcaca2c...feef47764b9ae49fa5cc28a07186db7905481297
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by Bug 990478 ? Jose can you take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(jmcanterafonseca)
(Assignee)

Updated

4 years ago
Assignee: nobody → jmcf
(Assignee)

Comment 6

4 years ago
Created attachment 8471427 [details]
22771.html

Ben,

Sergi, and Francisco are away on PTO. Please could you help me by reviewing this simple patch?

thanks
Attachment #8471427 - Flags: review?(bkelly)
(Assignee)

Comment 7

4 years ago
Joshua,

a patch has been proposed, once is r+ed and landed the problem will be fixed

thanks for spotting it
Flags: needinfo?(jmcanterafonseca)
Comment on attachment 8471427 [details]
22771.html

Looks good.  I did not test this on device.  r=me
Attachment #8471427 - Flags: review?(bkelly) → review+

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
(Assignee)

Comment 9

4 years ago
https://github.com/mozilla-b2g/gaia/commit/68e16451134c2ea7855621be9e49f1c405a883d3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Keywords: verifyme
v2.0: https://github.com/mozilla-b2g/gaia/commit/4d66e31ed2270a55ba3648f5a65e473a00aafff5
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.1 S2 (15aug)
Verified fix on affected branches:
- 2.0
- 2.1

Results:
Users are prevented from entering Settings menu after electing to export contacts ('Settings' [Gear] button doesn't exist during flow of 'Export Contacts' anymore).

===================================================================

Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202 (319mb) 
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Flags: needinfo?(pbylenga)
I can confirm Comment 11's findings for Master as well.

Environmental Variables:
Device: Flame Master
Build ID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.