Closed Bug 1050899 Opened 5 years ago Closed 5 years ago

Crash in GonkGPSGeolocationProvider::SetAGpsDataConn

Categories

(Core :: DOM: Geolocation, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla34
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- fixed

People

(Reporter: khuey, Assigned: kanru)

References

Details

(Keywords: crash)

Attachments

(1 file)

My Nexus 5 reliably crashes with a null dereference of mAGpsRilInterface when doing GPS at http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/GonkGPSGeolocationProvider.cpp#341.
I assume khuey is using B2G 2.1 and that 1.4 is also affected because regressing bug 1032063 was uplifted mozilla-b2g30_v1_4.
Kan-Ru: this crash is a regression from update_network bug 1032063.
Assignee: nobody → kchen
Flags: needinfo?(kchen)
Right. We ensure we have mAGpsInterface at that point but we have to check mAGpsRilInterface before use.
Flags: needinfo?(kchen)
Attachment #8473637 - Flags: review?(dougt)
Attachment #8473637 - Flags: review?(dougt) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fed7dac88deb
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
[Blocking Requested - why for this release]:

This fixes a regression of a 1.4+ bug.
blocking-b2g: --- → 1.4?
As a regression.

(In reply to Kan-Ru Chen [:kanru] from comment #8)
> [Blocking Requested - why for this release]:
> 
> This fixes a regression of a 1.4+ bug.
blocking-b2g: 1.4? → 1.4+
Comment on attachment 8473637 [details] [diff] [review]
Check mAGpsRilInterface before use

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1032063
User impact if declined: This crash fix is necessary for bug 1032063, which is a 1.4+ blocker that we'd like to fix on 2.0. That fix will improve geolocation and FMD on non-QC devices. (QC replaces our Gecko geolocation code with their own.)
Testing completed: Dolphin running 1.4
Risk to taking this patch (and alternatives if risky): Low risk. This patch just adds some null pointer checks.
String or UUID changes made by this patch: None
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.