Closed Bug 1051513 Opened 5 years ago Closed 5 years ago

Removed activities still exist after a first-run state

Categories

(Core Graveyard :: DOM: Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla34

People

(Reporter: kgrandon, Assigned: cwiiis)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file, 1 obsolete file)

STR:
1 - Remove an activity from a manifest, and run make install-gaia.
2 - Run the script here: https://github.com/AntonioMA/gaiatools/blob/master/resetApps.sh

Expected:
Activity that you removed is no longer an option.

Actual:
Activity that you removed remains.
The issue is that we fail to remove "old" activities for preloaded apps because we don't have the old manifest anymore. We can likely fix that by just removing all the activities for a given appId instead.
May have a patch for this, but having difficulty debugging... Will attach WIP if I make no progress.
Not an area of code I'm familiar with, so not really sure this is the right thing to do, but debugging lead me to think it is.
Attachment #8470984 - Flags: review?(fabrice)
Comment on attachment 8470984 [details] [diff] [review]
Fix updating web activity registration

Review of attachment 8470984 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm, thanks!
Attachment #8470984 - Flags: review?(fabrice) → review+
Carrying r+, just removing some redundant code. Will push when I'm awake and the tree's open :)
Assignee: nobody → chrislord.net
Attachment #8470984 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8471146 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/957e7446d3f7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Duplicate of this bug: 966901
Whiteboard: [systemsfe]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.