Closed Bug 1051746 Opened 5 years ago Closed 5 years ago

[MobileID] Get the proper ICC info

Categories

(Core :: DOM: Device Interfaces, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35
blocking-b2g 2.0+
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: ferjm, Assigned: ferjm)

References

Details

Attachments

(1 file, 1 obsolete file)

Summary: Get the proper ICC info by service ID → [MobileID] Get the proper ICC info by service ID
Assignee: nobody → ferjmoreno
Sorry, this one got out of my radar for a while :(...

[Blocking Requested - why for this release]: Without this fix in a multi-SIM scenario we may share the incorrect phone number with the consumer of the Mobile ID API. I think this needs to go on 2.0 because this breaks the Mobile ID feature sharing an incorrect number and it violates the user's privacy cause the user does not explicitly select the phone number that we share but other one.
blocking-b2g: --- → 2.0?
Attached patch v1 (obsolete) — Splinter Review
Duplicate of this bug: 1051749
Summary: [MobileID] Get the proper ICC info by service ID → [MobileID] Get the proper ICC info
Attached patch v1Splinter Review
Sam, this patch makes sure that we have the proper ICC information at all times.

We were not listening for the iccinfochange event and so our cache could be obsolete if any change on the ICC status occurred. Now we are listening for these event and clearing the caches when needed.
Attachment #8492205 - Attachment is obsolete: true
Attachment #8492969 - Flags: review?(spenrose)
Comment on attachment 8492969 [details] [diff] [review]
v1

Fernando -- the code looks good as best I can tell. I was not able to execute the new unit test because MOZ_B2G_RIL is not set for me, but I think that is an artifact of overriding the platform to get xpcshell to run. So r+, thanks!
Attachment #8492969 - Flags: review?(spenrose) → review+
Hi Bhavana, could you please kindly help triage 2.0? on this ? Thank you very much.
Flags: needinfo?(bbajaj)
https://hg.mozilla.org/mozilla-central/rev/5f470ac9f032
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Broken new feature = 2.0+.  Will this get uplifted automatically?
blocking-b2g: 2.0? → 2.0+
Needs b2g32 and aurora approvals for uplift.
Flags: needinfo?(ferjmoreno)
Comment on attachment 8492969 [details] [diff] [review]
v1

Approval Request Comment
[Feature/regressing bug #]: Mobile ID
[User impact if declined]:  Without this fix in a multi-SIM scenario we may share the incorrect phone number with the consumer of the Mobile ID API. I think this needs to go on 2.0 because this breaks the Mobile ID feature sharing an incorrect number and it violates the user's privacy cause the user does not explicitly select the phone number that we share but other one.
[Describe test coverage new/current, TBPL]: Unit tests added to the already existing ones.
[Risks and why]: Low risk. The only consumer of this feature is being developed by the same team, so any regression should be catch and fixed pretty soon.
[String/UUID change made/needed]: None
Attachment #8492969 - Flags: approval-mozilla-b2g32?
Attachment #8492969 - Flags: approval-mozilla-aurora?
Flags: needinfo?(ferjmoreno)
Attachment #8492969 - Flags: approval-mozilla-b2g32?
Attachment #8492969 - Flags: approval-mozilla-b2g32+
Attachment #8492969 - Flags: approval-mozilla-aurora?
Attachment #8492969 - Flags: approval-mozilla-aurora+
Flags: needinfo?(bbajaj)
You need to log in before you can comment on or make changes to this bug.