Error launching browser window: no XBL binding for browser

RESOLVED WORKSFORME

Status

()

Core
XBL
--
blocker
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Ron, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
After uninstalling 0.9.4m removing the directory and installing 0.9.5 
(5.0.0.9.5.2001101120) or build 0.9trunk2001101606 the browser gives and
error and doesn't start.

The trunk build gives "Error launching browser window: no XBL binding for 
browser"

0.9.5 build gives "Error creating browser instance"

Mail also doesn't display any controls.
(Reporter)

Comment 1

16 years ago
I tried a new nightly today, and the problem still is there. After the install 
I get this error message: 

Cannot find entrypoint of procedure ?ToNewCString@nsString@@QBEPADXZ in 
xpcom.dll

(translated from dutch)

When I try to restart the browser after the install I get the previous reported 
error message ( no XBL bindings for browser)

and yes I installed in a fresh directory after an uninstall of the old version.

(Reporter)

Comment 2

16 years ago
The profile from mozilla 0.9.4 was causing this. Starting the profile manager

mozilla -profilemanager

and creating a new default profile fixed the problem. Might be something that a
next build might automagically do if something goes wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
*** Bug 114889 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.