If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can get stuck in overscroll if child APZC gets a scroll offset update while parent is overscrolled

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: botond, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Basically, what I said I strongly suspect was happening in https://bugzilla.mozilla.org/show_bug.cgi?id=1040226#c0 (but wasn't in that case), is actually happening now with different STR:

1. Open http://people.mozilla.org/~bballo/apz-overscroll/index.html in the Browser app.
2. Zoom in.
3. Overscroll horizontally.

Actual results:
  You get stuck in overscroll.

Expected results:
  You do not get stuck.
Blocks: 1020045
(Reporter)

Comment 1

3 years ago
The simple fix of changing the call to CancelAnimation() in NotifyLayersUpdated() to CancelAnimationsForHandoffChain() runs into lock order problems. I could work around them, but the refactoring in bug 1039992 will make them go away, so unless someone other than me runs into this problem, I'll wait until bug 1039992 is fixed before fixing this.
(Reporter)

Updated

3 years ago
Depends on: 1039992
(Reporter)

Comment 2

3 years ago
I can't reproduce this bug in the absence of overscroll-during-panning (bug 1055361), so I'm going to de-prioritize it until we have STR with shipping features.
(Reporter)

Comment 3

3 years ago
Let's reopen or file a new bug if/when we have STR with shipping features.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.