Closed Bug 1052371 Opened 6 years ago Closed 6 years ago

ShutdownLeaks detector is deactivated and runs for mochitests other than bc

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(firefox31 unaffected, firefox32 unaffected, firefox33 fixed, firefox34 fixed)

RESOLVED FIXED
mozilla34
Tracking Status
firefox31 --- unaffected
firefox32 --- unaffected
firefox33 --- fixed
firefox34 --- fixed

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Those are regressions from bug 886570.
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Attachment #8471513 - Flags: review?(akachkach)
The one leak we see so far is reproducible locally for me:

toolkit/mozapps/extensions/test/browser/browser_openH264.js | leaked 2 window(s) until shutdown [url = about:addons]
Depends on: 1052409
Comment on attachment 8471520 [details] [diff] [review]
0001-Bug-1052371-Fix-m-bc-shutdown-leak-detector.patch, v2

Review of attachment 8471520 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me! The "suite_end" part is probably due to the fact that we don't process the messages generated through Python by those handlers (and that was previously generated by the JS side).
I went ahead and checked that "TEST-START | Shutdown" is still printed by mochitest-plain, mochitest-chrome and robocop.
Attachment #8471520 - Flags: review?(akachkach) → review+
Oops, Android mochitests were failing. Pushed a tiny bustage fix:

https://hg.mozilla.org/integration/fx-team/rev/9b26ce378971
Depends on: 1052756
https://hg.mozilla.org/mozilla-central/rev/c865443dfb0c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Blocks: 1046162
You need to log in before you can comment on or make changes to this bug.