crash in mp4_demuxer::Index::ConvertByteRangesToTimeRanges(nsTArray<mozilla::MediaByteRange> const&, nsTArray<mp4_demuxer::Interval<long long> >*)

VERIFIED FIXED in mozilla34

Status

()

defect
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mossop, Assigned: ajones)

Tracking

({crash})

unspecified
mozilla34
All
macOS
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-c53bc628-cda1-471f-a5f2-6f5022140813.
=============================================================
Seeing this crash on a lot of pages using the video tag with media.apple.mp4.enabled true. Sites like youtube.
media.fragmented-mp4.exposed true is the important pref here.

Some of these may be me; I was hitting this working on bug 1047486, which I think is different.

In this one I'm seeing ConvertByteRangesToTimeRanges called with a null 'this' pointer. Possibly an initialization race.
I believe bug 1050060 will resolve this. Closing for now; please reopen if you see new crashes after tomorrow's nightly.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1050060
Resolution: --- → FIXED
:rillian fixed in nightly 34.0a1 (2014-08-14) for me.
Assignee: nobody → ajones
Target Milestone: --- → mozilla34
Thanks for confirming.
Flags: qe-verify+
Couldn't reproduce this crash with Nightly 2014-08-13 and 2014-08-12 on Mac OS X 10.10 nor 10.9.5. No crash encountered on Firefox 34 beta 1 build 2 (Build ID: 20141014134955) on the same OS.

No crash reports present in Socorro for [@ mp4_demuxer::Index::ConvertByteRangesToTimeRanges(nsTArray<mozilla::MediaByteRange> const&, nsTArray<mp4_demuxer::Interval<long long> >*)] signature: https://crash-stats.mozilla.com/query/?product=Firefox&version=Firefox%3A34.0b&range_value=4&range_unit=weeks&date=10%2F20%2F2014+13%3A00%3A00&query_search=signature&query_type=contains&query=mp4_demuxer%3A%3AIndex%3A%3AConvertByteRangesToTimeRanges%28nsTArray%3Cmozilla%3A%3AMediaByteRange%3E+const%26%2C+nsTArray%3Cmp4_demuxer%3A%3AInterval%3Clong+long%3E+%3E*%29&reason=&release_channels=&build_id=&process_type=any&hang_type=any

Based on the above results and comment 5 (Thanks, Sonny!), marking accordingly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.