The default bug view has changed. See this FAQ.

Increase Android 2.3 mochitest chunks

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1028293 +++

In bug 1051131, mochitest-4 is frequently failing due to exceeding the job timeout. I am slightly hesitant to increase the number of chunks because some other chunks are running in a much shorter time. But I don't immediately see an alternative...

I'm thinking of increasing from 12 to 16 chunks.
(Assignee)

Updated

3 years ago
Assignee: nobody → gbrown
The sad thing is, the chunking is inherently unpredictable, so it's hard to say for sure what effect it'll have on min/max chunk runtime.

FWIW, we should also really look into enabling chunk-by-dir on Android/B2G mochitest-plain at some point. Right now, it's enabled by default on desktop only.
(Assignee)

Comment 2

3 years ago
:kmoir -- Do you think the timeouts might be related to bug 1047467?
Flags: needinfo?(kmoir)
(Assignee)

Comment 3

3 years ago
Created attachment 8472700 [details] [diff] [review]
Increase Android 2.3 mochitest chunks to 16 (buildbot)
Attachment #8472700 - Flags: review?(kmoir)
(Assignee)

Comment 4

3 years ago
Created attachment 8472701 [details] [diff] [review]
Increase Android 2.3 mochitest chunks to 16 (mozharness configs)
Attachment #8472701 - Flags: review?(kmoir)

Comment 5

3 years ago
Regarding comment #2, no this is not related to bug 1047467 because the mochitests all run on tst-linux64-spot-* instances which are all m1.medium.  These are not the tests I changed to run on c3.xlarge et al.  So this is a different issue. I'll assume that the mochitests don't need a more power instance type than m1.medium and look at the patches.
Flags: needinfo?(kmoir)

Updated

3 years ago
Attachment #8472700 - Flags: review?(kmoir) → review+

Updated

3 years ago
Attachment #8472701 - Flags: review?(kmoir) → review+
(Assignee)

Comment 6

3 years ago
https://hg.mozilla.org/build/mozharness/rev/83208943d5d8
https://hg.mozilla.org/build/buildbot-configs/rev/693c954bcde6
(Assignee)

Updated

3 years ago
Attachment #8472700 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8472701 - Flags: checked-in+
Status: NEW → ASSIGNED
Looks like this broke a test across the various repos: 
https://tbpl.mozilla.org/php/getParsedLog.php?id=45974436&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=45976969&tree=Mozilla-Central
https://tbpl.mozilla.org/php/getParsedLog.php?id=45977661&tree=Mozilla-Inbound

Updated

3 years ago
Blocks: 1054087
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1051131
See Also: → bug 1138462
You need to log in before you can comment on or make changes to this bug.