Closed Bug 1053648 Opened 7 years ago Closed 6 years ago

drive.google.com sends Desktop version to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: karlcow, Assigned: karlcow)

References

()

Details

(Whiteboard: [mobile-compat-form] [country-all] [serversniff] [sitewait])

Site: https://drive.google.com/
drive.google.com sends Desktop version to Firefox OS

:: Steps To Reproduce

1. Without being logged to Google and a Firefox OS smartphone
2. Go to https://drive.google.com/ or https://docs.google.com/


:: Expected Result

Receive the mobile content like Chrome

:: Actual Result

receiving Desktop content.

:: Additional Information

Software Version: 2.1
Device Information: Flame
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Hardware: Other → ARM
See Also: → 754754
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-all] [serversniff] [contactready]
This was recently reported over at https://webcompat.com/issues/350
Status: UNCONFIRMED → NEW
Ever confirmed: true
When not logged, currently we receive the accounts for Mobile, for example.
https://accounts.google.com/ServiceLogin?service=wise&passive=1209600&continue=https%3A%2F%2Fdrive.google.com%2F%23&followup=https%3A%2F%2Fdrive.google.com%2F&ltmpl=drive&emr=1

Once the credentials are entered, we receive the desktop version.
https://drive.google.com/?authuser=0#my-drive

It can be easily tested with faking the Firefox OS UA on Desktop. 

When testing with a fake Chrome Mobile UA on Firefox Desktop, we receive a UI for mobile which seems to be working. 

Contacting Google.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form] [country-all] [serversniff] [contactready] → [mobile-compat-form] [country-all] [serversniff] [sitewait]
Answer from Google.

> Thanks for the report Karl. I've forwarded it along to the Google Drive team and I'll let you know what they say.
Google Answer:


> We've determined that this is an issue with a system 
> we use for parsing device types. There's now an internal 
> bug tracking this, reference number 17969678.
Any news on this? I believe this is what I'm seeing on Android too?
The UI for Firefox Android is working, and the UI for Firefox OS is still the desktop one. 
We didn't receive any further comments from Google.
This is fixed.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.