Closed Bug 754754 Opened 8 years ago Closed 6 years ago

Google Docs - New Mobile Site Renders on Android Stock, Not on Fennec Native

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(blocking-kilimanjaro:+)

RESOLVED FIXED
blocking-kilimanjaro +

People

(Reporter: jsmith, Assigned: karlcow)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [country-all] [serversniff] [sitewait])

Attachments

(2 files)

If a user visits google docs on fennec native, then they will be given an older mobile-optimized site. On the stock browser, the more recent optimized mobile site renders. UA sniffing is evident.

Changing the user agent to the android stock browser on fennec native results in nothing being rendered if you visit docs.google.com.

Note - The suboptimal mobile site appeared to be okay for viewing one spreadsheet I had, but it was impossible to a view a document. The more recent optimized version does allow this functionality correctly.
blocking-kilimanjaro: --- → ?
No longer blocks: google-evangelism
blocking-kilimanjaro: ? → +
The universal extra tools bar as seen in the first screenshot sounds like a global include (bug 780896 for Google). Otherwise, the sites seem the same here minus the bar.
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 15 → unspecified
Is any proactive work being done to fix this kind of problems? Is there something Firefox can do, say start supporting webkit prefix CSS properties to alleviate the problem? 

I understand that's not the right long term approach, but from user's viewpoint, if some of the popular web apps are broken in Firefox on Android (and Firefox OS down the road), they might stop using Firefox now and then it might be too late to get them back.
Duplicate of this bug: 869729
Mozilla is in frequent contact with Google about the outstanding issues with Google properties. Unfortunately, any hack to try and resolve issues like this bug will typically require a combination of UA spoofing, -webkit prefix property aliasing, and, in some cases, JS fixes. This is not a trivial nor robust solution.
I understand the viewpoint, but don't you think the Mozilla has more to loose in Firefox adoption on Android and Firefox OS then Google?

Hoping Mozilla does something for compatibility with mobile web besides evangelizing with the site providers, as that's a long drawn out process.

Likely this is not the forum for this kind of discussion, so I'll stop here.
Whiteboard: [country-all] [serversniff] [contactready]
Oh love. 
http://docs.google.com/
Receiving the mobile form (good)
Entering the account and password.
Getting into an infinite redirection loop.
Assignee: nobody → kdubost
Problem since last month :( ?

I saw bug 947780 filed this weekend.
So this is not solved. It doesn't seem to be a temporary mistake. 
I have contacted Alex.
Status: NEW → ASSIGNED
Whiteboard: [country-all] [serversniff] [contactready] → [country-all] [serversniff] [sitewait]
Loops indeed - though oddly enough only on the real device. When I spoof as Firefox for Android on desktop I didn't see the loop..?!
See Also: → 1053648
This seems to be solved to me.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.