[e10s] Scrolling by dragging the scroll handle breaks if the mouse leaves the window

RESOLVED FIXED in mozilla35

Status

()

Core
Event Handling
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: cwiiis, Assigned: Felipe)

Tracking

(Blocks: 1 bug)

Trunk
mozilla35
x86
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
If you scroll by dragging the scroll handle, scrolling will stop if the mouse cursor leaves the window. If you let go of the mouse button while the cursor is outside of the window, re-entering the window will cause scrolling to get 'stuck' to the mouse until you click.
Felipe, working theory is you have a dupe of this assigned to you. Assigning this to you so you can handle it appropriately.
Assignee: nobody → felipc
Blocks: 997462
tracking-e10s: --- → +
(Assignee)

Comment 2

4 years ago
This bug has similarities with bug 1003943 and bug 1003934. It's not only related to the scrollbar dragging, but any click-and-hold operation (like selecting text). When there's a mousedown, we have to start capturing the mouse at the OS level, so that we're informed of all the mouse actions even outside our window. But this doesn't seem to happen with e10s content.
(Assignee)

Updated

4 years ago
Component: General → Event Handling
Product: Firefox → Core
(Assignee)

Comment 3

4 years ago
Created attachment 8481619 [details] [diff] [review]
Capture events at remote target

Are there other kinds of events, other than mouse events, that would require the same capturing treatment?
Attachment #8481619 - Flags: review?(bugs)
Comment on attachment 8481619 [details] [diff] [review]
Capture events at remote target

Would be a bit safer if you would check first that nothing is capturing the
event already.
So
if (dispatchedToContentProcess) {
->
if (dispatchedToContentProcess && !nsIPresShell::GetCapturingContent()) {
Attachment #8481619 - Flags: review?(bugs) → review+
(Assignee)

Comment 5

4 years ago
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #1)
> Felipe, working theory is you have a dupe of this assigned to you. Assigning
> this to you so you can handle it appropriately.

Yeah, the dupes were bug 992423 and bug 947911. I'll dupe them forward to this one as I ended up working on the patch/review here.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 947911
https://hg.mozilla.org/mozilla-central/rev/c3cd97cf00dd
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35

Updated

2 years ago
Depends on: 1251634
You need to log in before you can comment on or make changes to this bug.