Closed Bug 1053950 Opened 6 years ago Closed 4 years ago

Use promises for DebuggerClient.detach

Categories

(DevTools :: Debugger, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1227474

People

(Reporter: jryans, Unassigned)

References

Details

As noted in bug 1049835, the dbg-client's detach requires callees to execute the passed callback to continue the detach process.

This should be rewritten with promises / generators instead so that dbg-client does the work to keep things moving, not each client instance.
Component: Developer Tools → Developer Tools: Debugger
Priority: -- → P3
Summary: Rework dbg-client's detach sequence → Use promises for DebuggerClient.detach
Done in bug 1227474.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227474
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.