[e10s] fix activation from about:home

RESOLVED FIXED in Firefox 41

Status

defect
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: ally, Assigned: Felipe)

Tracking

unspecified
Firefox 41
x86_64
Windows 8
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(e10sm7+, firefox41 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
No description provided.
Reporter

Updated

5 years ago
Assignee: nobody → ally
Reporter

Updated

5 years ago
tracking-e10s: --- → ?
Reporter

Updated

5 years ago
Blocks: e10s-social
Reporter

Updated

5 years ago
Blocks: old-e10s-m2
Flags: firefox-backlog+
Flags: firefox-backlog+
Flags: firefox-backlog+
Reporter

Updated

5 years ago
Assignee: ally → nobody
Move old M2's low-priority bugs to M6 milestone.
Activation should work after bug 915547 lands, however about:home has larger issues, other tests are disabled in browser/base/content/test/general/browser.ini
Points: --- → 3
Flags: qe-verify+
Assignee: nobody → mconley
So I think I need some more context for this bug. Shane - can you tell me how I can reproduce / recognize this bug? What does it mean to "activate from about:home"?
Flags: needinfo?(mixedpuppy)
see browser/base/content/test/social/browser_aboutHome_activation.js and bug 1029942

as well, in browser.ini

[browser_aboutHome_activation.js]
skip-if = e10s # Bug 1053965 "cw.ensureSnippetsMapThen is not a function", also see general/browser.ini about:home comments


So it may be a general issue with snippets, a general issue with about:home, or possibly something with socialapi (though iirc activation in e10s works)
Flags: needinfo?(mixedpuppy)
I don't think this should block the uplift (and hold) on Aurora. Like, we should definitely fix this, but I suspect we can live with this on Aurora for a little while. Re-nomming.
Assignee: mconley → felipc
Status: NEW → ASSIGNED
Iteration: --- → 40.3 - 11 May
So it turns out the feature is working properly, it was just the test that didn't work with e10s. I had to refactor the test to make some parts of it to run in the content process. I did this using the ContentTask.spawn function which helps a lot by running a function defined in the test, in a framescript, and returns a promise that resolves when the function resolves in the content process.

I'm trying my luck at dropping the aSnippetsMap.delete("snippets") clean-up hoping it's not necessary, because doing so will be slightly inconvenient.
Attachment #8604477 - Flags: review?(mixedpuppy)
Test passed (the failure on treeherder is unrelated, from another patch in my queue that I forgot to remove)
Iteration: 40.3 - 11 May → 41.1 - May 25
Attachment #8604477 - Flags: review?(mixedpuppy) → review+
https://hg.mozilla.org/mozilla-central/rev/2b4f5c21c27a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Shane, since Felipe is away, could you please give me some information(s) on how to reliably verify this fix? With older & latest builds, I can see that 'Share this page' button is not available on about:pages and the already enabled social providers (Goal.com, Cliqz, Delicious and so on) are successfully visible in the sidebar, one by one. Thanks in advance!
Flags: needinfo?(mixedpuppy)
Alexandra, This is a unit test fix, you don't need to do anything here.
Flags: needinfo?(mixedpuppy)

Updated

4 years ago
Flags: qe-verify+

Updated

4 months ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.