Can not drag main window by title bar

RESOLVED FIXED in Thunderbird 34.0

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: henrik, Assigned: Paenglab)

Tracking

32 Branch
Thunderbird 34.0
x86_64
Windows 8.1
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird32 fixed, thunderbird33 fixed, thunderbird34 fixed, thunderbird_esr3132+ fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140811180644

Steps to reproduce:

Tried to move main Thunderbird window by dragging the title bar


Actual results:

Main window can not be dragged via mouse on the title bar


Expected results:

Window being dragged
Here it works. You are using the default theme and have no userChrome.css tweaks? Above the tabs where is a space where you can drag the window. And on the right of the last tab the whole titlebar space is available for dragging the window.

Please can you attach a screenshot which show why you can't drag the window?
Flags: needinfo?(henrik)
Your note gave me a thought.. yes, I'm using standard theme and do not use any customization to the userchrome.css ... but what I have that may not be very common is the menu bar enabled (ie.. file/edit/view/go/ etc showing).. with that enabled you can't drag the window...  when I turn 'menu bar' off then I can.
Flags: needinfo?(henrik)
Are you using a High contrast Windows 8 theme? Only then is the menubar above the tabs and then I can confirm in the area there the menubar is is the window not draggable.
I'm using a standard theme. I checked the same setup in Firefox 32 (ie.. view menu bar on) and I can drag the Firefox window. 

I do have the mail.tabs.autoHide configuration set to true
(In reply to Henrik Bruun from comment #4)

> I do have the mail.tabs.autoHide configuration set to true

Ah okay, now it's clear. I think it makes no sense to have mail.tabs.autoHide=true and mail.tabs.drawInTitlebar=true. Please can you set mail.tabs.drawInTitlebar to false and you have a normal titlebar where you can drag the window.
Please can you confirm if it works with mail.tabs.drawInTitlebar set to false?
Flags: needinfo?(henrik)
Yes, it works with drawInTitleBar set to false.  Thank you.
Flags: needinfo?(henrik)
Thank you Henrik.

I'll use this bug to fix the issue I saw in comment 3.
Posted patch 1054260.patchSplinter Review
Unfortunately I have to create a new rule and can't use the previous because Win8 matches also under HC themes with -moz-windows-compositor.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8474257 - Flags: review?(josiah)
Attachment #8474257 - Flags: review?(josiah) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/9fbe7a04fc90
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 34.0
Do we want to backport this to TB 31? If so, please request approval.
Comment on attachment 8474257 [details] [diff] [review]
1054260.patch

[Approval Request Comment]
User impact if declined: window not dragable with menubar on HC Win8 themes
Testing completed (on c-c, etc.): in c-c
Risk to taking this patch (and alternatives if risky): low, only CSS
Attachment #8474257 - Flags: approval-comm-esr31?
Attachment #8474257 - Flags: approval-comm-beta?
Attachment #8474257 - Flags: approval-comm-aurora?
Attachment #8474257 - Flags: approval-comm-esr31?
Attachment #8474257 - Flags: approval-comm-esr31+
Attachment #8474257 - Flags: approval-comm-beta?
Attachment #8474257 - Flags: approval-comm-beta+
Attachment #8474257 - Flags: approval-comm-aurora?
Attachment #8474257 - Flags: approval-comm-aurora+
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.