Closed Bug 1054352 Opened 6 years ago Closed 6 years ago

Replace videos in FTE tutorial

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86
macOS
defect
Not set
normal

Tracking

(feature-b2g:2.1, tracking-b2g:backlog, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
feature-b2g 2.1
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: pdol, Assigned: tedders1)

References

Details

(Keywords: feature, Whiteboard: [ft:systemsfe])

Attachments

(2 files)

6.34 MB, application/zip
Details
46 bytes, text/x-github-pull-request
sfoster
: review+
arcturus
: review+
Details | Review
UX will be updating the videos for the FTE tutorial to include the latest designs.  This bug is to track replacing the videos.
Target Milestone: --- → 2.1 S3 (29aug)
Assignee: nobody → tclancy
Attached file FTE Videos
Hey Ted,

I'm currently syncing box with the final videos here:
https://mozilla.box.com/s/tr9culczyrmhq3qbyj4v

But it's going to take over an hour....so i've included a zip file with all the videos.  The zip contains 4 videos in 4 sizes.

1. Universal Search
2. Notification Tray
3. Sheets
4. Vertical Home screen (with bookmarks)

Each video is in 1x, 1.5x, 2x and 2.25x
Flags: needinfo?(tclancy)
Attached file FTU updates
This patch also addresses Bug 1046955 and Bug 938279.
Attachment #8481644 - Flags: review?(sfoster)
Attachment #8481644 - Flags: review?(francisco)
Flags: needinfo?(tclancy)
I've not had time to run through all the scenarios, just looked over the patch and walked through the first-time-use tutorial. Just one thing noted in the PR - you'll need a new string for the wording change in tutorial-vertical-scroll-tiny. If you've tested each upgrade scenario, consider this my r+ with that change. I'll resume this later otherwise. 

Note (for anyone wanting to ui reivew or verify this) you'll need to build with GAIA_DPPX=1.5 to get the higher-res videos onto the Flame.
Comment on attachment 8481644 [details] [review]
FTU updates

One more issue noted in the PR. I ran through 1.3, 1.4, 2.0 upgrade and with the indicated change to finish_screen.js all the right things seem to happen. Has r=me with those changes, but IANAP (I am not a peer)
Attachment #8481644 - Flags: review?(sfoster) → review+
Comment on attachment 8481644 [details] [review]
FTU updates

Did a quick pass and tried migration from 2.0 to 2.1 and works for me.

Happy to see Sam r+ too.

Thanks for the work!
Attachment #8481644 - Flags: review?(francisco) → review+
Keywords: checkin-needed
Ted - one of the python tests compares output against a string, which needs to be updated for this to land
Flags: needinfo?(tclancy)
Removing checkin-needed for now until we make the simple string update. Thanks for bringing that up Sam.
Keywords: checkin-needed
Blocks: 938279
In master: https://github.com/mozilla-b2g/gaia/commit/eb578b9a5ef135e2d2464463c435450c94e704e0
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Blocks: 1046955
Comment on attachment 8481644 [details] [review]
FTU updates

[Approval Request Comment]
This patch updates the FTU Tutorial to explain features of Firefox 2.1 to the user.

[Bug caused by] (feature/regressing bug #): 
1054352, 1046955, and 938279. 

[User impact] if declined: 
If declined, the user won't understand how to use their phone.

[Testing completed]: 
Green TPBL run: https://tbpl.mozilla.org/?rev=c656b87efc0db69f6f0d18e8039f9bc8f3482deb&tree=Gaia-Try

[Risk to taking this patch] (and alternatives if risky):
All the changes are in the FTU app and don't affect anything else. I guess it's possible that the new videos might make the build size too large.

[String changes made]:
There are a few new strings. They're taken from the UX spec.
Attachment #8481644 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8481644 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
The issue is verified in Flame 2.1 and Flame 2.2:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141003000203
Gaia: 9861c61ec302fb0316c753a2e1c0f592180515fd
Gecko: da68900d1c66
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141003040207
Gaia: d711d1e469eeeecf25a02b2407a542a598918b2c
Gecko: b85c260821ab
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The new video clips are included during FTE tutorial pages.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.