Closed Bug 1054442 Opened 8 years ago Closed 8 years ago

[FTE] Remove progress bar from setup flow

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86
macOS
defect
Not set
normal

Tracking

(feature-b2g:2.1, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
Tracking Status
b2g-v2.1 --- verified

People

(Reporter: jsavory, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe])

User Story

Remove the progress bar from the FTE setup to compensate for the space needed for the status bar. As well, the progress bar is not entirely accurate when additional screens are added to the flow and therefore does not add much value for the user. 

UX FTE Spec:
https://mozilla.box.com/s/8yihqi76dui0e2mb88mv

Attachments

(2 files)

No description provided.
Assignee: nobody → mhenretty
Blocks: 1035250
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S3 (29aug)
Fernando, could you take a look here?
Attachment #8475577 - Flags: review?(fernando.campo)
feature-b2g: --- → 2.1
Comment on attachment 8475577 [details] [review]
[Gaia PR] remove progress bar

Nice!, tested on nightly and device and looks great.

Just one question: should we also get rid of the Firefox Accounts internal progress bar?
Attachment #8475577 - Flags: review?(fernando.campo) → review+
(In reply to Fernando Campo (:fcampo) from comment #2)
> Comment on attachment 8475577 [details] [review]
> [Gaia PR] remove progress bar
> 
> Nice!, tested on nightly and device and looks great.
> 
> Just one question: should we also get rid of the Firefox Accounts internal
> progress bar?

That's a good question. Re-directing to Jacqueline.
Flags: needinfo?(jsavory)
I feel that it would be best if we could remove the progress bar from the Firefox Accounts sign up as well, since we are removing it from the rest of the FTE flow. 

Ni? on John to check to see if this proposal is fine as he is working on the UX for Firefox Accounts.
Flags: needinfo?(jsavory) → needinfo?(jgruen)
(In reply to jsavory from comment #4)
> I feel that it would be best if we could remove the progress bar from the
> Firefox Accounts sign up as well, since we are removing it from the rest of
> the FTE flow. 
> 
> Ni? on John to check to see if this proposal is fine as he is working on the
> UX for Firefox Accounts.

Fine by me!
Flags: needinfo?(jgruen)
(In reply to [:jgruen] from comment #5)
> (In reply to jsavory from comment #4)
> > I feel that it would be best if we could remove the progress bar from the
> > Firefox Accounts sign up as well, since we are removing it from the rest of
> > the FTE flow. 
> > 
> > Ni? on John to check to see if this proposal is fine as he is working on the
> > UX for Firefox Accounts.
> 
> Fine by me!

Filed a bug to do the same for FXA https://bugzilla.mozilla.org/show_bug.cgi?id=1056972
master: https://github.com/mozilla-b2g/gaia/commit/d75847c00e44ea679474737869fc7eb877422222
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This issue has been verified successfully on Flame2.1.
Reproducing rate: 0/5
See attachment: Verify_Flame_FTEBar.mp4

Flame2.1 build version:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Status: RESOLVED → VERIFIED
Attached video Verify_Flame_FTEBar.MP4
You need to log in before you can comment on or make changes to this bug.