Closed Bug 1035250 Opened 6 years ago Closed 5 years ago

[User Story] Show connectivity status during FTE

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- verified

People

(Reporter: pdol, Assigned: mikehenrty)

References

Details

(Keywords: feature, Whiteboard: [ucid:System222], [ft:systemsfe] [2.1-feature-qa+])

User Story

As a user, I want to be able to see my connectivity status during the FTE so that I know if my mobile data is being used for steps that require a server connection.

Acceptance Criteria:
1. For any step that requires a server connection in the FTE, I can determine whether I am connected to WiFi or mobile data.
2. Implementation matches UX spec.

UX FTE Spec:
https://mozilla.box.com/s/8yihqi76dui0e2mb88mv

Attachments

(3 files)

No description provided.
Blocks: 1015338
blocking-b2g: --- → backlog
User Story: (updated)
Duplicate of this bug: 1042983
Target Milestone: --- → 2.1 S3 (29aug)
QA Whiteboard: [2.1-feature-qa+]
Flags: in-moztrap?(jsmith)
QA Contact: jsmith
QA Whiteboard: [2.1-feature-qa+]
Whiteboard: [ucid:System222], [ft:systemsfe] → [ucid:System222], [ft:systemsfe] [2.1-feature-qa+]
Flags: in-moztrap?(jsmith) → in-moztrap?(mozbugs.retornam)
QA Contact: jsmith → mozbugs.retornam
Flags: in-moztrap?(mozbugs.retornam) → in-moztrap?(gchang)
QA Contact: mozbugs.retornam → gchang
Depends on: 1054442
Assignee: nobody → mhenretty
Duplicate of this bug: 1041905
Add the test cases.
https://moztrap.mozilla.org/manage/cases/?filter-suite=755
Flags: in-moztrap?(gchang) → in-moztrap+
Hi Alive, can you give me feedback on the IAC approach for showing statusbar icons as you progress through ftu?

(I know this needs squashed, registers multiple handlers for settings sometimes, fails tests, has curse words, etc. but this will all be cleaned up before review)
Attachment #8479626 - Flags: feedback?(alive)
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

Delay the settings listener seems not bad,
but I still prefer we always observe but not showing it initially. (Maybe a hidden class on the dom element by default.)

Could we:
* Have a list of initial hidden icons.
* Show all the icons once ftu is skipped/done.
* Show a specific icon according the IAC message.

Also please note:
* Since you have statusbar in ftu now, we should prevent rocketbar to be opened during ftu since this is not expected.
Attachment #8479626 - Flags: feedback?(alive)
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

I'd like to get another round of feedback before the final review. Known issues are that I need to add unit tests for the iac stuff, and fix some marionette tests.

(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> Comment on attachment 8479626 [details] [review]
> [Gaia PR] FTU with IAC to show progressive statusbar
> 
> Could we:
> * Have a list of initial hidden icons.

All the icons are hidden initially except battery. I added a comment to this effect in the code.

> * Show all the icons once ftu is skipped/done.

Done.

> * Show a specific icon according the IAC message.

Done.

> Also please note:
> * Since you have statusbar in ftu now, we should prevent rocketbar to be
> opened during ftu since this is not expected.

This is also done. There are two ways to trigger the rocketbar opening, one is to click on the search bar, the second is to click on the utility tray touch listener. The search bar is hidden with css, and the utility tray is disabled while we run FTU. So rocketbar will not be shown in FTU (unless you launch it later as a regular app).
Attachment #8479626 - Flags: feedback?(alive)
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

I have concern for ftu part; I hope we keep these two module as standalone as possible. See the comments and lemme know if you have problems.
Attachment #8479626 - Flags: feedback?(alive)
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

Alive, can you take another look?
Attachment #8479626 - Flags: review?(alive)
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

r+ with nits
Attachment #8479626 - Flags: review?(alive) → review+
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

Nits addressed. Rob, can you take a look at this?
Attachment #8479626 - Flags: ui-review?(rmacdonald)
Attachment #8479626 - Flags: ui-review?(jsavory)
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

I'll let Jacqueline decide on the flag as she's the approver. 

My main comment is that no notifications indicator should be shown (icon or ambient) as the utility tray cannot be opened and notifications cannot be accessed. Based on Michael's irc comments, this sounds like a regression of some sort.
Attachment #8479626 - Flags: ui-review?(rmacdonald)
(In reply to Rob MacDonald [:robmac] from comment #12)
> Comment on attachment 8479626 [details] [review]
> [Gaia PR] FTU with IAC to show progressive statusbar
> 
> I'll let Jacqueline decide on the flag as she's the approver. 
> 
> My main comment is that no notifications indicator should be shown (icon or
> ambient) as the utility tray cannot be opened and notifications cannot be
> accessed. Based on Michael's irc comments, this sounds like a regression of
> some sort.

Yup, that's a bug we can polish up after FL.
Comment on attachment 8479626 [details] [review]
[Gaia PR] FTU with IAC to show progressive statusbar

This is looking great to me! 
The only change I would make aside from the ones previously mentioned is to have the wifi indicator appear as soon as the connection is established rather than when the user taps to the next page. However, this is a nice to have and would be more of a polish item.
Attachment #8479626 - Flags: ui-review?(jsavory) → ui-review+
master: https://github.com/mozilla-b2g/gaia/commit/0bf1094ab2917559a291c98242bdffab1fec9dd2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I had to back this out due to failures on b2g-inbound. It looks like it was not failing on gaia-try, but perhaps it's landing in conjunction with another bug caused failures?

https://tbpl.mozilla.org/php/getParsedLog.php?id=47089050&tree=B2g-Inbound

https://github.com/mozilla-b2g/gaia/commit/807578c629c37f832506b65c876bf0ab969d5f51

I'll help look at this once the tree is green.
Status: RESOLVED → REOPENED
Flags: needinfo?(mhenretty)
Flags: needinfo?(kgrandon)
Resolution: FIXED → ---
It seems like this in combination with the utility tray refresh cause the utility tray to be dragged down as well when you swipe down, so our tests caught a real bug.
Flags: needinfo?(kgrandon)
Attached file Github pull request
Hey Mike - I think that this will probably fix it. The problem is that the statusbar/utility tray depend on touch event listener ordering. If this works feel free to land it however you see fit.

Here is the fix for the tests: https://github.com/KevinGrandon/gaia/commit/5dca8f1a3cb4b51971d45a8c5f1b5bde015eddd3
Attachment #8481815 - Flags: review?(mhenretty)
Flags: needinfo?(mhenretty)
Comment on attachment 8481815 [details] [review]
Github pull request

Thanks for that Kevin.
Attachment #8481815 - Flags: review?(mhenretty) → review+
We have a lot of intermittents on Gij, but there is a green run on the PR so I'm relanding.
master: https://github.com/mozilla-b2g/gaia/commit/d424dc89d8c1e790b311cec3ab3adb3e3d388406
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1061924
This issue is verified fixed on Flame 2.1(319mb)

Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

STR
1. Initiate First Time Use in settings
2. Go through every page on FTU including links requiring internet to connect to
3. Observe the Status bar Icons

Actual: Status of internet shows correctly on status bar
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Depends on: 1062753
Adding spec so I can link to it from other bugs.
Depends on: 1062998
Please disregard comment 22

This issue cannot be verified at this time because this two issues have not been resolved:

bug 1062753 (Empty SIM 1 & SIM 2 icons are not shown in title bar in FTE when all SIM cards are taken out) 

bug 1062998 (SIM signal statusbar icons should appear on SIM Manager screen)
Status: VERIFIED → RESOLVED
Closed: 6 years ago5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
No longer blocks: 1063305
Depends on: 1063305
Verified @
Gaia      fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/fb5e796da813
BuildID   20140903000204
Version   34.0a2
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.