Closed Bug 1054491 Opened 5 years ago Closed 2 years ago

Sound rocker not locked when in lock screen

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hub, Unassigned, Mentored)

References

Details

(Whiteboard: [lang=js])

Attachments

(1 file)

The sound rocker isn't locked when I'm in the lock screen. This is bad because this mean that randomly in my pocket the phone will switch to either be completely annoying (volume up) or make me miss message (silent mode) when it is normally in "vibrate".

My Android phone doesn't do that.

This is important.

Flame, 2.0.
Mentor: dietrich
Whiteboard: [lang=js]
The sound keys should only be locked if no music is playing. If music is playing when locked the user should still be able to adjust the volume. It should also be possible to adjust the volume on incoming calls without having to unlock the screen.

This patch checks if the System is locked and then further checks for the appropriate audio channel.

Since it seems that this is important user functionality unit tests should probably be created.
Attachment #8515602 - Flags: review?(alive)
Comment on attachment 8515602 [details] [review]
patch to block volume keys on lock screen

Cannot r+ before UX agrees and having tests.
Attachment #8515602 - Flags: review?(alive) → ui-review?(firefoxos-ux-bugzilla)
Flagging Jacqueline on lock screen.
Flags: needinfo?(jsavory)
Comment on attachment 8515602 [details] [review]
patch to block volume keys on lock screen

Jacqueline is already set to ni? here; also assigned the ui-review flag to her.
Attachment #8515602 - Flags: ui-review?(firefoxos-ux-bugzilla) → ui-review?(jsavory)
After trying out the patch, I noticed that I wasn't able to adjust the volume while the music was paused. I think it might be better if when the music controls are appearing on the lockscreen, the user has the ability to adjust the volume whether the music is playing or paused. 

Flagging Rob as FYI as he is currently lead for lockscreen.
Flags: needinfo?(jsavory) → needinfo?(rmacdonald)
(In reply to jsavory from comment #5)
> After trying out the patch, I noticed that I wasn't able to adjust the
> volume while the music was paused. I think it might be better if when the
> music controls are appearing on the lockscreen, the user has the ability to
> adjust the volume whether the music is playing or paused. 
> 
> Flagging Rob as FYI as he is currently lead for lockscreen.

Agreed. 

And thanks, Hubert, for identifying this issue.
Flags: needinfo?(rmacdonald)
(In reply to Frank from comment #1)
> The sound keys should only be locked if no music is playing. If music is
> playing when locked the user should still be able to adjust the volume. It
> should also be possible to adjust the volume on incoming calls without
> having to unlock the screen.

But also *only* if the screen is turned on. It doesn't make sense to allow to ajust the volume without seeing the set level.
Currently (build ID 20150820200530) you can change the sound volume while the screen is off.

Sebastian
Duplicate of this bug: 893698
Comment on attachment 8515602 [details] [review]
patch to block volume keys on lock screen

Cleaning up old review flags
Attachment #8515602 - Flags: ui-review?(jsavory) → ui-review-
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.